Radio not loading more songs when using Spotify Connect

Status: Won't Fix
I have a Samsung Galaxy S7 with Android 6 and a Yamaha RX-V481 AV-Receiver which supports Spotify Connect. I am living in Germany and got Spotify Premium from the german "Telekom"

Normal Music streaming over it works fine but once I try to listen to a Radio, it plays the few songs loaded when you start the Radio, but does not load more songs while playing (Screenshot 1). That leads to it stopping playing once it played the last song in the initial list (Screenshot 2). The behavior can be compared with the behavior of a normal playlist without shuffle and without repeat mode.
Once I turn Connect off and listen to the Radio on my phone, the Radio works like it should.
I also noticed that in the "now playing" view it does not show the radio station it currently plays when listening over Connect (Screenshot 3). While listening on the phone it does. I don't know if those issues are related.

I already tried updating the Firmware of the AV-Receiver and reinstalled the Spotify App without success. When using Spotify on Windows 10 it is the same. I never tried it with an other AV-Receiver or something like that because I don't have another one, but when I start an Radio on my computer and switch to my phone from there the Radio works fine, but I guess that cannot be compared as the phone can run Spotify on its own.

For me it loks like a problem with Spotify, so I tried it here first, but if it isn't, I can also try to contact the Yamaha support!
Screenshot_20161009-040751.png
Screenshot_20161009-040612.png
Screenshot_20161009-040739.png

Hey folks!

 

We've researched this quite a bit, and it seems users experience this if they're using a very old firmware on their speakers.

 

We'd recommend updating your device's firmware to the most up-to-date version, and giving things another shot.

 

Thanks for your patience while we confirmed this on our end.

Comments
70boss429

Dang, over 2 years later and Spotify has not corrected this issue???  And we pay for this service????

Jon-P

Maybe their IT team are still learning, they should be trained soon.

KamuiJitsu

I get exactly the same problem with Spotify MacOS app. New tracks just don't load for the radio, and very often the whole radio station doesn't load at all. I don't have any blocks and have a premium account.

I tried starting radio from my Galaxy S7 phone, radio starts, but new tracks don't load on both phone and mac app.

5ncnni_q8-m8e

Dear Spotify,

is it really not possible no fix this?

I have two Yamaha devices, both updated to the latest firmware (R-N602 FW 1.32 1812, Musiccast 20 FW 1.84 0738) and the problem persists for both of them. Please help.

btaubs714
spotify doesnt care at all about this issue. moving to pandora and amazon
music
Jon-P
Now that I use Deezer no longer frustrated with Spotify.