Samsung Galaxy S7/S7 Edge w/SD Card Offline Tracks Desyncing

Hey folks!

 

We're investigating an issue at the moment with our friends at Samsung regarding offline tracks desyncing on a Samsung Galaxy S7 Edge when using an SD Card.

 

In the meantime, we'd suggest following these steps;

 

  • Reinstall
  • Restarting your device
  • Hold off starting Spotify for around 10-20 seconds after the system has started
  • Also, make sure your firmware and Spotify version is up-to-date.

We'll update this thread when we receive any more updates from our teams.

 

Thanks,

Jim

 

Hey folks!

 

Thanks for all your comments here. We really do appreciate your patience. As we haven't received any reports since the new Android version has been released, we're going to be closing this thread for now. 

 

If you're still having trouble, the following has helped many users;

 

- A clean reinstall.

- Making sure you're rocking the latest version of Spotify and Android.

- Holding off from starting Spotify for around 10-20 seconds after your device has started up.

 

If you're still having trouble then please let us know.

 

Cheers :)

 

 

 

Related Issues

Comments
Autotime
Roadie

Hi I expirience this problem 100% of the time with the SD Encryption enabled and about 5% of reboots once a month without SD encryption on.   I initially started with SD encryption off but then realized that enabling it would show the bug immediately.

 

On reboot of phone spotify does not see the SD card immediately and the Data is lost requiring redowloading of all songs resulting in over 100gb of Data in one month transferred.

 

Support by email informing me they are both aware and working on this problem I have yet to see any results v5.8.xxx is still having this issue.

 

As a premium customer it would be nice to use a newer version at some point on my Galaxy S7.

 

To help you pinpoint the bug I will communicate solutions that work once again.

 

Workaround solution is to use an application disabler. 
- Disable spotifty
- Reboot

- Enable spotify after boot.

 

Fully working solution is to downgrade to 5.2.885 and disable auto-updates

(all newer versions tested fail)

 

 

 

MaryC1
Spotify Legend
Status changed to: Under investigation

Hey @Autotime, thanks for reaching out to us for help!

 

Could you let us know the Android version you've got installed? Also, have you give it a try from a different phone or device? Does the same thing happen with your SD card? 

 

Keep us posted.

Autotime
Roadie

Hi I have android version 6.0.1 the phone is a galaxy s7 edge.  The same issue occurs with the galaxy s7.  I have not tested this onmy family members galaxy s5 neo.

 

I have both factory reset my phone and tried multiple sd cards.  I had to stop experimenting as hard as I was not just using hundreds of gb on wifi to re-download but several gb of mobile data obtaining album covers and other cached data every time I used spotify in the car.

 

 

Regarding the details of the bug.

This issue happens on all versions of spotify AFTER 5.2.0.885.

 

This issue occurs when the sd card is not ready immediately on boot and spotify service starts.  

 

If several new applications have been installed to the SD card like vr games it will show the issue even without sd encryption on however is hard to duplicate or predict the random occurrences.

 

Further if you proceed to encrypt the sd card the issue will occur 99.5% of the time even if only spotify is using the sd card for storage.

 

The message on 5.2.0.885 is on boot is the sd card is not accessible but goes away when acceaable and spotify works 100% ok.

 

On newer version this message is not shown on boot.  Spotify cannot access the sd card and defaults to local storage.   Even if the location is set back to sd the cached data.  Downloaded play lists are lost. 

 

Deleting all spotify folders.  Factory resetting the phone and using different sd cards does not help.

 

Before testing older versions I purchased the Samsung application disabler from Google play  (this app works on phones without root).  By disabling the application before rebooting.  After reboot enabling the application resulted in zero data loss and normal working.

 

I started testing old versions to as I didn't have this issue previously during my first few weeks of using your app.

 

Currently I have installed v5.2.0.885 as I may reboot anytime without issue.

 

I have tried 5.3.xx 5.4.xx 5.5.xx 5.6.xx 5.7.xx 5.8.xx and all newer versions have this issue.   I am not the only person on this forum with this issue.

 

Simply obtaining a galaxy s7 or s7 edge and encrypting the sd card, setting the storage location to sd and making a Playlist available offline will allow you to duplicate the issue in your development office.

 

I suggest testing with 5.2.0.885 first to see there is no data loss on reboot then update the version.

 

I believe this was broken when spotify fixed the a storage location bug for other models of phones or android os changes between spotify version 5.2 and 5.3.

 

Regarding fixing the issue

Simply if the spotify service from starting on boot slept for 30 seconds if the SD card was previously found and no longer found to wait for it to become ready or even an advanced setting that is stored internally on the phone that forces spotify to use the external sd and wait for it to become ready would work.

 

The other issue could be that some settings not just cached data for offline (songs) are stored on the sd vs internally causing the data not to be found and defaulting to storing internally and ignoring all previous application data. 

 

On some occasions the complete account is forgotten and others just the songs.

 

This bug is very duplicatable and I expect that many of your users have higher end phones are experiencing the same problem as there is many users on the forum with this problem. 

 

I cannot comment for other brands of handsets with encrypted sd cards but maybe some other folks can chime in here with their makes and models.

 

I have emailed support and followed up with them.  They say they are aware of the problem and working on it but it is obviously a series of canned responses as the replys I get don't make any sense or have any consistency with the reported bug.

 

I am sure the users here appreciate just like me your attention to this valid bug.

Jim
Spotify Legend
Status changed to: Under investigation
 
Autotime
Roadie

Could I note.

 

Hold off starting Spotify for around 10-20 seconds after the system has started

  • -> you can't do this without using an application disabler because spotify runs on boot in the background and this solution works

 

 

Could you possible check this information in this bug.

https://community.spotify.com/t5/Ongoing-Issues/Samsung-Galaxy-S7-S7-Edge-Encrypted-SD

I have the same issue but with an encrypted SD card it happens everytime not just once in a while.

Joe
Community Legend

Good to hear. There seems to be a fault with the S7 Edge. I've noticed a couple of times notifications showing the SD card being unmounted then remounted for no apparent reason.

Jim
Spotify Legend

Hey @Autotime

 

Thanks for the heads up. We've been informed that this also applies to encrypted SD cards.

 

paulocholanda
Casual Listener

Hello. I'm experiencing the same issue on my Asus Zenfone 2 + SD card. I have already reset the offline devices list, and my spotify shows no problem in detecting the external storage (which I had formated before my last attemp of downloading offline tracks, just to make sure is not a problem with the external memory). However, if I restart or turn off/on the phone, some GBs of previously stored tracks just disappear and I have to download all over.

joydeekaren
Casual Listener

thanks Jim, i already did reinstall the app for 4x already. when i restart it, it will work for just a few songs but will crash and say no storage area found. my phone is a note 2 galaxy.

Autotime
Roadie

@MaryC1 you guys still need more information?  

 

I don't understand why I have been requested to give more information on this bug by email today?

 

Is support not able replicate the problem?

 

Please ask me exactly what you need instead of a broad question "we need more information please contribute more so we can identify the issue"... are you kidding?  because of that is the case someone isn't reading the information given.

 

My exact model is g935w8 (s7 edge)

Further this issue was on both my g935w8 s7 edge. 

 

How exactly can I help you??

 

Where did you have an issue duplicating this problem.