Help Wizard

Step 1


Samsung Gear Fit 2 Pro Offline play is incredibly buggy

I just purchased the Samsung Gear Fit 2 Pro.

Soley to use the Spotify on runs and leave my phone.

I log into the stream wifi. 

Download my playlists.

All the songs on the playlist have the green arrow.

I turn on offline play in the settings.

Below are the issues that are occurring:


- Some songs do not play at all.

- Often when I click on a song it will play a different song.

- Many songs will play the first few seconds and then stop playing.

- I have to constantly delete the downloaded music and redownload the playlist.

- Some songs have the cloud with the "x" on it but still plays offline. 


Hey everyone!


As we haven't had any updates about this in a while, we'll be closing the thread.


If you need our help again, don't hesitate to open a new one.


All the best.


I have uninstalled the application on my iphone and GF2P and reinstalled the newest versions. The problem still persists. 


Please fix your app. 



- My watch is paired with my Samsung Galaxy Note 5

- The Spotify app is set to "STREAM" and not "REMOTE" connection. So songs and playlists are downloaded through why Wi-Fi.

- Samsung Gear Fit 2 Pro version is: r365xxu2aqg9

- Spotify Software Version: Boost Software License - Version 1.0

- I've reinstalling the app and rebooting the watch. Same Issues occur.





Keep in mind Premium features are only available for iOS users, so there's a chance those are not working for you properly since you're trying to pair it with a Samsung Galaxy Note 5. You can find more info here. You mentioned offline songs worked on your Android device, could you let us know if you were able to use these Premium features on your watch? 


We'll see what we can suggest. 


Hey folks,


Thanks for getting back to us.


@DrDragonFace5 you mentioned the issue's still happening for you with your iOS. Sorry to hear!

Just so we're sure, are you following the exact steps here:


Also, although you've already reinstalled, it doesn't look like you're running the newest versions just yet.

Would you be happy to try that once more for us? Let us know if you're still experiencing this, and everything's up-to-date. If you could also re-confirm your versions for us afterwards, that'd be super helpful 🙂


We'll be sure to continue helping, don't worry.


If anyone else is still having trouble, keep us in the loop too. We'll work together to see what we can suggest.


Many thanks,



I'm facing exactly the same problem. It effectively make the offline play completely unusable for me. Seems like the app on Gear Fit 2 pro have problem with song management, possibly in app database is broken. I tried to clear cache, reinstall, and re login with no success. Please fix it... I'm running galaxy s7 with latest Spotify app on Gear fit2. It was working when I first used it. But somehow it was broken after the first few days. 



Hi @LoneGun, welcome to the Spotify Community!


We'd recommend giving a try to the suggestions we already posted. Also, does it makes any difference if you pair your Samsung Gear Fit 2 Pro to a different smartphone? 


As a test, try reinstalling the app with these steps and sync only one playlist. Lastly, test syncing just one album to see if it works.


Be sure to keep us posted on the results 🙂


Same issues here. Spotify version 1.1.24


Actually my problem is fixed with the recent Gear Fit 2 Pro OS update. I guess it's a problem with Tizen. Its working perfectly now!


That's great to hear @LoneGun! If you need any more help, don't hesitate to get back to us. 


@SGT_T and @Thomashouser, can you make sure that you have the latest firmware update on your Gear Fit devices?


Keep us in the loop 🙂 


Yes, I have the most recent firmware. However, I installed spotify before the firmware update. So, I uninstalled/reinstalled it so we'll see. Still having trouble with "My Collection" saying "No items. Please refresh." A specific playlist seems to be ok to see offline, so we'll see if all is well when I work out tomorrow morning.