Saved album song selection bug

Hello,

 

Below I've added a GIF demonstrating a bug in the latest update with selecting songs within saved albums, when a song is selected for playing, Spotify jumps to the first track in the album and starts playing that instead. I'm seeking assistance in fixing this issues as currently the only way I can select a song from a saved album is to use the next track button until my desired song is playing, and it's rather frustrating.

 

spotify.gif

 

Thanks-

Hey all!

 

Thanks for all your reports. We've been given the all-clear from the teams backstage and will be marking this thread as "Fixed" for now.

 

If you're still having any trouble, a clean reinstallation will help to get things back on track.

 

If you have any questions, feel free to give us a shout 😁

Comments
fntms
Newbie

+1

Annoying bug!

Jacob
Community Legend

Hey @fntms and @buddy148, thanks for coming to the Spotify Community!

Could I ask you two to try a full reinstall of the Spotify app and let me know if this continues to occur?

Looking forward to your response 🙂

buddy148
Casual Listener

I've fully un-installed, cleared all cache files, and then reinstalled.

 

Works at first on the version of Spotify installed by the installer, but after it updates to the latest version through the updater, the bug comes back.

Jacob
Community Legend

@buddy148,

Thank you for going through those troubleshooting steps!

I've moved this thread into the "Ongoing Issues" board and I will escalate this to Spotify staff so that it gets the attention it needs.

Thanks again for coming to report this issue 🙂

Jacob
Community Legend

To further diagnose this problem, what operating system are you using and what is your exact Spotify version?

fntms
Newbie

Version 1.0.51.693.g6ea1e7f6

Win 7

 

I can't uninstall and reinstall (on my office PC, will try at home).

buddy148
Casual Listener

@Jacob

 

Spotify version:

1.0.51.693.g6ea1e7f6

 

System information: 
OS Name Microsoft Windows 10 Pro
Version 10.0.14393 Build 14393
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name **********
System Manufacturer System manufacturer
System Model System Product Name
System Type x64-based PC
System SKU Unsupported
Processor Intel(R) Core(TM) i5-6600 CPU @ 3.30GHz, 3301 Mhz, 4 Core(s), 4 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. 0224, 17/07/2015
SMBIOS Version 3.0
BIOS Mode UEFI
BaseBoard Manufacturer ASUSTeK COMPUTER INC.
BaseBoard Model Not Available
BaseBoard Name Base Board
Platform Role Desktop
Secure Boot State On
PCR7 Configuration Binding Not Possible
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume2
Locale Australia
Hardware Abstraction Layer Version = "10.0.14393.206"
Username ************
Time Zone E. Australia Standard Time
Installed Physical Memory (RAM) 16.0 GB
Total Physical Memory 15.9 GB
Available Physical Memory 11.9 GB
Total Virtual Memory 18.3 GB
Available Virtual Memory 13.2 GB
Page File Space 2.38 GB
Page File C:\pagefile.sys
Hyper-V - VM Monitor Mode Extensions Yes
Hyper-V - Second Level Address Translation Extensions Yes
Hyper-V - Virtualisation Enabled in Firmware Yes
Hyper-V - Data Execution Protection Yes

Additional Processor Information:
CPU Vendor: GenuineIntel
CPU Brand: Intel(R) Core(TM) i5-6600 CPU @ 3.30GHz
CPU Family: 0x6
CPU Model: 0x5e
CPU Stepping: 0x3
CPU Type: 0x0
Speed: 3312 Mhz
4 logical processors
4 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported
AES: Supported
AVX: Supported
CMPXCHG16B: Supported
LAHF/SAHF: Supported
PrefetchW: Supported

Video Card:
Driver: NVIDIA GeForce GTX 960

DirectX Driver Name: nvd3dum.dll
Driver Version: 21.21.13.7878
DirectX Driver Version: 21.21.13.7878
Driver Date: 23 Feb 2017
OpenGL Version: 4.5
Desktop Color Depth: 32 bits per pixel
Monitor Refresh Rate: 60 Hz
DirectX Card: NVIDIA GeForce GTX 960
VendorID: 0x10de
DeviceID: 0x1401
Revision: 0xa1
Number of Monitors: 3
Number of Logical Video Cards: 3
No SLI or Crossfire Detected
Primary Display Resolution: 2560 x 1080
Desktop Resolution: 6400 x 1080
Primary Display Size: 31.42" x 13.15" (34.06" diag)
79.8cm x 33.4cm (86.5cm diag)
Primary Bus: PCI Express 4x
Primary VRAM: 4095 MB
Supported MSAA Modes: 2x 4x 8x

Hope this helps in reproducing the bug.

 

Regards-

SimonBuxx
Newbie

I've got the same problem, it occurs only in the saved albums section. The previous version was fine, but it updates automatically...

Jacob
Community Legend

Hey everyone,

Some Spotify staff members and I are looking into the issue 🙂 If more people have this issue, please continue posting system info. We should have some more information on this very soon!

In the meantime, does this still occur in offline mode?

buddy148
Casual Listener

@Jacob,

 

The bug is still present while in offline mode both from being toggled within Spotify and when I've disabled my network adapter.

Related Issues