Announcements

Skipping songs doesn't work properly

Status: Closed

I can't skip songs by pressing the button on my earphones twice. I have already tried deleting the app and the thing that seems to work is logging in and out of my account but that resets after I restart my phone so now to get it to work i have to log in and out every time I turn my phone on. Iets really annoying is there a fix? I have the Huawei p7.

Hey there, @Moryseye

 

Thanks for all of the info you've provided here! Rest assured we've passed it along now 🙂

As the issue hasn't continued for you on your new phone, we're going to close this thread up now.

If you need us again in the future however, don't hesitate to reach out.

Take care, and have a great day.

/M

Comments
Moryseye

My headset control doesn't work on my huawei p7, when I want to skip a song i have to press the button on my headset 3 times instead of 2 and i can't skip to a previous song. This only seems to get fixed by logging in and out but I have to log in and out every time i restart my phone which is really annoying, does anyone know how to fix this? (I use the app and i have spotify premium btw)

MaríaCamila
Status changed to: Need more info

Hi @Moryseye, welcome to the Spotify Community!

 

Could you let us know what operating system and Spotify version you're using? Also, do you remember if this started happening after a specific update or event?

 

Maybe reinstalling the app with the steps here could help you with this.

 

Hope to hear from you soon 🙂

Moryseye

@MaríaCamila I am using my huawei p7(phone from 2014 with android 5.1.1) , the app version is  8.4.26.770 armV7 and I don't have spotify prmium for that long so I only just now noticed it when i was listening and it's driving me nuts. I have already reinstalled the app twice.

I hope this helps 🙂

ZullyB

Thanks for the info, @Moryseye!

 

Can you give it a try with other earphones and let us know if the same happens? Also, if you could use another device to test it, that'd be very helpful. 

 

Let us know how it goes 🙂

Moryseye

@ZullyB @MaríaCamila Different headphones doesn't change a thing. When I log into my account on a different phone it works fine. What I've noticed is that the first song when I have restarted my phone is skippable but after that it's messed up again

Mara_F

Thanks for trying @Moryseye

 

Can you let us know what headphones you're using to control the skips on your device and how is it connected to your phone (Bluetooth)? Also, did you give it a shot with the same headphones on the different device you mentioned?

 

We'll see what we can suggest.

Moryseye

@Mara_F @ZullyB @MaríaCamila The headphones I use are JBL e15 (I think), it uses my phone's headphone jack and I did use my regular headphones on the other device and it worked on the other phone.

Aichel

Thanks for that info, @Moryseye!

 

We've tested this from our side and can confirm that we can reproduce this situation. Would it be possible for you to try and update the OS on your phone? We can confirm that this works well when using a device that runs on Android 6.0 or above.

 

We'll keep an eye out for your reply 🙂

Moryseye

@Aichel nope Huawei doesn't update this phone any more 😞