Help Wizard

Step 1


Sleep timer not working with podcasts

Hey there,


We've received reports for the Sleep timer not working, i.e. the next podcast episode plays after the timer has expired.


This is being investigated.

Hey folks,


Thanks for your patience while we looked into this issue.


We’re happy to say that this should now be fixed for everyone! Just make sure your app is updated to the latest version.


If you're still having trouble, make sure to post a new thread in the relevant help board here.




I am having the same issue lately. It’s painful. I actually use podcasts to help me fall asleep and now the podcast never end 😂

I am on iOS and the issue started over the last couple of days. 


Same problem across all of my iOS devices


Also having the same problem after updating to iOS 16.1.1.

Status changed to: Need more info

Hey folks,


Thanks for reporting this to us.


First, we'd like you to turn off Autoplay from the app settings and see if this brings any difference. If not, we'd recommend trying a clean reinstall of the app on your device by following the steps here.


If after that you’re still having trouble with this, could you provide us with the following info:

  • device + OS version
  • exact Spotify version
  • a link to the podcast episode you're not able to use the sleep timer with
  • does a different account on your device reproduce the experience?

Once we have that, we will pass it on to the relevant team, who will look further into it.




Same issue here. 
iphone 7

ios 15.7.1

Spotify 8787512

All podcasts affected, but this was the one I noticed first


Hi. I have the same issue with the sleep timer using it for podcasts. It worked fine until some time ago. (iOS)


Same issue, past 2 days. iphone 11 pro, spotify version

hoping for a fix asap, hate having my downloaded podcasts play without me noticing 😞


I had been having this issue as well for at least a week, that's how i ended up here, but in the middle of typing out this message I noticed there was a Spotify update in the app store and that fixed it for me.

I'm going to go ahead and share the requested details anyway in case it's helpful to anyone else..

Device: iPhone 14 Pro
iOS version: 16.1.1
Spotify version:, just updated to version (which seems to have fixed the issue)

Also worth noting: Before the app update, I tried turning off Autoplay and that did allow the sleep timer to work again. Not the ideal solution, but better than being woken up in the middle of the night by a 3rd sleep story!

I switch between a few different podcasts and playlists w/ the sleep timer and had the issue with all of them.


I'm having this issue too... I wake up in the middle of the night like four episodes past the one I set the "end of episode" timer on. It probably started about a week ago and has been consistent since then.


iPhone 14 Pro

iOS 16.0.2

Spotify version

It's happening with all my podcasts, but here's an example of the last one (don't judge me, I'm a medical nerd):

I don't have access to any other accounts on this device.



Hello, since few days I am as well having this issue, but only when listening via my Sonos speakers. It always was laggy but the music at least stopped playing after a few seconds. Now it just acts like I didn't set the timer. When e.g. listening directly on my phone (Android 12, Galaxy S20 FE 5G), the sleep timer always works instantly. So maybe some Sonos update in the background is faulty?