Help Wizard

Step 1


Sleep timer not working with podcasts

Hey there,


We've received reports for the Sleep timer not working, i.e. the next podcast episode plays after the timer has expired.


This is being investigated.

Hey folks,


Thanks for your patience while we looked into this issue.


We’re happy to say that this should now be fixed for everyone! Just make sure your app is updated to the latest version.


If you're still having trouble, make sure to post a new thread in the relevant help board here.




I am having the same issue. I tried updating, reinstalling turning off auto tune and nothing worked… 
iPhone 11 Pro Max 


Same issue I tried reinstall and turned off auto play. 
version -

iPhone XR


Same issue, persists after turning off Autoplay and a clean reinstall of the app.

Device version: iPhone 6s - iOS 15.7.1

Spotify version:

Podcast: Tested multiple episodes of this podcast (


The specific issue is this: when a podcast episode ends with a sleep timer set to "End of Episode," Spotify seems to stop playing anything (the Now Playing bar disappears), but then a new episode will begin playing as though there had been no sleep timer set at all. Interestingly enough, the issue disappears when an episode is downloaded and Airplane mode is turned on (i.e. Spotify no longer has any network access); the sleep timer functions perfectly under these conditions. Maybe a recent iOS update changed something?


Sleep timer doesn't work when connected to Google home mini, when playing music or podcasts. When timer is approaching end, it says it will stop at end of current song but just carries on.

  • OnePlus 7
  • Android 11
  • Spotify

Same issue here persists despite reinstalling and despite Spotify apparently being aware of this for a week. A good fix: use the Apple Podcasts app…

Status changed to: Under investigation

Hey everyone,


Our tech folks are aware of this and are currently investigating it.


In case you're experiencing this issue, make sure to give it a like and provide us with the following info (if you haven't already):

  • Your device's make, model and OS version.
  • The version of Spotify you're running.
  • The URL of the podcast episode you're not able to use the sleep timer with.

Thanks! We'll pass the info on to our internal teams so they can look further into this. Rest assured we'll keep you posted here as soon as we have any new information to share, so Subscribe to the thread to stay tuned!




I’ve been having this issue for the past week! I have an iPhone XR iOS 16 and my Spotify app is up to date


I see the same issue. I rely on this a lot and it stopped working with the latest update.


workaround: use timer on your iPhone 

set timer to whatever time and select “stop playing “ at the end of timer 


I’m having this issue too. Next episode plays even though I’ve selected End of Episode on the sleep timer. Version is, iOS 16.1.1, iPhone 13


Same issue here. iPhone 12 Pro iOS 16.1.1

No matter which podcast I choose, Spotify will play all night long as soon as there is another episode.