Song link opens the album and doesn't play

When i click a link to direct me to a song, it doesn't play the song it just shows the album which the song is from. I then have to search for the song in the album and click it before it plays.  It's just on my app. on my computer it goes directly to the song, it doesn't play it but it links to it. The problem started maybe 3 days ago.

 

I have reinstalled spotify app, cleared the cache and autoplay is enabled.

 

Any help would be great

Premium, UK, htc u11, android 9

 

Cheers,

JJ

Hey folks,

 

Thanks for your patience while we looked into this issue.

 

We’re happy to say that this should now be fixed! Make sure your app is updated to the latest versionAs a heads-up, it'd be great for you to double-check your device's operating system is also updated to the latest version.

 

If you're still having trouble, make sure to post a new thread in the relevant help board here.

 

Thanks!

Related Issues

Comments
Moderator
Moderator

Hey @dubbulj,

 

Thanks for reaching out about this here in the Community.

 

Would you mind sharing the link you mentioned so we can test this on our end? 

 

It'd be great if you'd check for any available Android and Spotify updates and double-check you didn't miss any before trying with the link again. 

 

We'll look out for your reply and be here if there's anything else we can help with!

Casual Listener

Hey thanks for replying,

 

My phone is fully updated and spotify was reinstalled this morning before i sent the first message, so no updates needed there.

 

It's not one particular song link, it is any song link. And not just ones i receive either, also links I send to other people. I have also checked with other people that the same link opens a song on their end, yet on my end it opens the album only. Here's an example that it has happened on today:

 

https://open.spotify.com/track/01p0lvcsH28Rmeu5uvSOU2?si=BUGpeaXnR-qfCnhk4vpoHg

 

Thanks for your help!

Visitor

Hi both my other half and I have this same issue along with another colleague at her work. They share a track of the day but every time it just links to the album and not the individual track. 

 

Edit: My other half and I both have Huawei phones fully updated and spotify is updated. I have tried reinstalls and restarts but this issue is still present. 

Visitor
Newbie

The same thing happens to me and others I have asked who have Android phones (Samsung and Pixels). It seems to still work for my friends with iPhones. It started recently for me as well- I think within the last week. 

Visitor

The same with me, any of the links I tried doesn't work 

Visitor

Have any solutions to this issue been found? Thanks. 

Visitor

Same thing with my One Plus 7 Pro. Tried reinstalling, clearing cache, relogging, different song links...but problem continues to occur. Very annoying.

Visitor

Hey Mario any updates on a solution? Song links are completely broken for me along the lines of these other comments. I've reinstalled the app twice, restarted my phone, cleared the cache, etc. Nothing seems to work. I'm assuming this has to be related to a recent update. I'm on a OnePlus 5T.

Visitor

Plan

Premium

Country

United Kingdom

Device

Samsung Galaxy S9+

Operating System

Android 10

 

My Question or Issue

 

Recently noticed that when sharing specific songs with my friends via WhatsApp that none of the links seem to auto play the desired song. This used to work fine as that is what the WhatsApp group is used for between my friends - playlists & songs.

 

Even links that I share do not seem to play whenever clicked, it just takes you to the album that the song is from. Any solutions to this or things to try? This feature had been working without fault up until maybe 2 or 3 weeks ago.

 

Thanks