Announcements

Spotify App crashes on iPhone using USB-Connection in the car

Status: Fixed

I use Spotify Version 6.5.0.1665

on an iPhone 4S

 

I like to listen to spotify in the car, I do this since I got Spotify premium, so I know, it worked before. There have been no changes made with the car software, so thats noch the point.

 

I have a BMW without iDrive, which means, I just use Spotify by USB-connection, but the moment I plug the USB-Cable on my iPhone4S the Spotify-App freezes I cannot navigate or start music.

After a few seconds the app crashes and I have to reopen the app with the USB cable still plugged in.

When I stop the car and want to unplug the iPhone, the same happens.

After unplugging the app freezes and after a few seconds it crashes.

Really annoying when you listening to an audiobook with over 100 titels and you have to search the right titel again.

 

It worked before, I did this all the time, listening at home with headphones, get into the car and just listening still to the same title by just plugging the USB-cable in, but now the app crashes everytime.

 

What I did till now:

I did try this with a different account from a friend.

I reinstalled the app

I reseted the iPhone

 

Btw. with amazon prime music everything works just fine!?

That's great to hear @boardy1980

 

We're happ that it seems to be working for you now. As we've seen other reports of this being fixed, we'll get this issue closed off for now.

 

If you do spot any further issues, please feel free to create a new Ongoing Issue thread and we'll take a look.

 

Thanks 🙂

Comments
boardy1980

Hi @Mara_F,

 

any news?

Because I can't really use spotify like I'm used to with my LG Soundbar or in my car.

This is not funny, 'cause I'm still paying premium account fee, although the app doesn't work bug-free on my device.

boardy1980

Hi @Mara_F,

 

do you need more info?

Mara_F
Status changed to: Under investigation

Hey @boardy1980

 

We're sorry for the delay, thanks for trying out and giving us that info. 

We passed this on to the right folks but in the meantime, we'd recommend using Spotify with Test 1 or Test 2 so you don't have any trouble playing your music. 

 

We'll be changing the status to Under Investigation for now.

 

Stay tuned for any updates 🙂 

Kayleigh

 Hey @boardy1980,

 

Whilst they're investigating, the Tech team have asked for the following information:

- What head unit is in your vehicle? To find this out, can you send us over the vehicles VIN number? 

 

Once we have the above, we'll pass this onto the right folks, and let you know once we've had an update. 

 

Thanks for bearing with us.

 

Kayleigh

 

boardy1980

Hi @Kayleigh,

 

ok, the VIN number of my car is F20 (BMW 116d EfficientDynamics 5-doors from 2012).

But as I wrote before, the same issue happens with the LG soundbar. So it isn't just about the car.

 

Do you need any more info?

Jim

Hey @boardy1980

 

Happy New Year! I hope you're well. 

 

Thanks for the VIN number. We've passed this onto the tech folks behind the scenes and hope to have an update from them soon. In the meantime, please make sure that your devices are all up-to-date.

 

Thanks again for bearing with us 🙂

Melody

Hey!

 

We hope you're well.

 

We're just checking in to let you know that this is still with the right folks.

As soon as we have any more info, we'll get back to you.

 

We really appreciate your patience here 🙂

 

Thanks, and take care.

 

/M

boardy1980

Thanks for your reply, I hope to hear from you soon.

Jim

Hey @boardy1980!

 

Thanks for bearing with us. We're currently investigating this backstage with our tech folks and hope to have some news to share soon. 

 

In the meantime, please make sure that everything is up-to-date 🙂

Lee

Hey everyone!

 

Our devs are still working away at this. Thanks for stating patient. We'll be sure to let you know as soon as we hear anything.

 

Lee

Env: prod