Spotify + Chromecast Audio Connection Keeps Dropping! Pls Help!

Plan

Premium

Country

USA

Device

iPhone X, iPhone 8, Chromecast Audio (3 devices), Motorola MG7315 modem/router

Operating System

iOS 13

 

My Question or Issue

Hi. We have 3 Chromecast Audio devices on my home network connected via a single Motorola MG7315 modem/router. All devices are confirmed to be running the latest firmware. We cast Spotify from either an iPhone XR or iPhone 8 running iOS 13. We have the latest Spotify app version on our phones. All Chromecast audio devices have <60 dBm signal strength. Lately we've been having an issue where Spotify is randomly dropping the connection to the Chromecast Audio devices. It doesn't matter whether one of us is casting to a single Chromecast Audio device or group of devices. But if a group of devices is playing, they all stop together when the casting "drops." Sometimes the issue happens several times within in an hour, requiring us to reconnect the device within the Spotify app each time to resume casting. It's super frustrating! The drops seem to happen at random, and it doesn't matter which phone is casting.  The phones can be sitting untouched/locked when the casting is interrupted, so it doesn't seem like obvious app interference on iOS. We only have ~8 devices connected to the home network, and there's nothing out of the ordinary about them (e.g., a TV, a couple of iPhones, MacBooks, Chromecast Audio devices), so it's not obvious that there would be device interference. Please help with ideas! The Spotify/Chromecast Audio setup had been working really well for a couple of years before this issue started presenting itself a couple months ago. Thank you so much!

 

Hey folks,

 

We're seeing reports that during playback the connection to Chromecast Audio devices is randomly dropping out.

 

We can confirm the right teams are aware of this, and they're looking into it.  If you’re experiencing this issue, we'd first recommend deleting and reinstalling the Spotify app, rebooting your device, router, as well as Chromecast and make sure that all devices are up to speed with any software updates.

 

In case the issue persists, let us know by adding your +VOTE and the following details in a comment below:

  • Make and model of the device(s) this is happening on.
  • The Exact version of the operating system.
  • The Exact version of Spotify.
  • The Chromecast firmware version.
  • Are you playing via voice commands or Connect?

Once we have that, we will pass it on to the relevant team, who will look further into it.

 

We'll be keeping an eye out for your replies, thanks!

Related Issues

Comments
Moderator
Moderator
Status changed to: Under investigation

Hey folks,

 

We're seeing reports that during playback the connection to Chromecast Audio devices is randomly dropping out.

 

We can confirm the right teams are aware of this, and they're looking into it.  If you’re experiencing this issue, we'd first recommend deleting and reinstalling the Spotify app, rebooting your device, router, as well as Chromecast and make sure that all devices are up to speed with any software updates.

 

In case the issue persists, let us know by adding your +VOTE and the following details in a comment below:

  • Make and model of the device(s) this is happening on.
  • The Exact version of the operating system.
  • The Exact version of Spotify.
  • The Chromecast firmware version.
  • Are you playing via voice commands or Connect?

Once we have that, we will pass it on to the relevant team, who will look further into it.

 

We'll be keeping an eye out for your replies, thanks!

Casual Listener

- iOS 13.4 iphoneX 

- Spotify v. 8.5.49.1123

- Chromecast 3  1.42.172094

- connect from Spotify app

 

Crash app after 2-5 mins

Regular

- iOS 13.3.1 iPhone 7 and 8 and iPad mini

- Spotify v. 8.5.49

- Chromecast Audio (4 units) firmware - 1.42.172094

- Connect from Spotify app

 

music dropping  out constantly. Also takes ages to connect to Chromecast audio device(s).

 

currently switched to Soundcloud, works as It should - connection to Chromecast audio is immediate and no audio drop outs or disconnects.

 

Please fix ASAP

 

 

 

 

Newbie

Pixel 3a Android 10 latest

2x  Google mini in stereo mode latest fw

Latest Spotify app

Google mini keep disappearing in cast menu spotify

Restart of Spotify something makes them reappear

Other apps can stream fine to mini's when Spotify looses them

 

 

 

 

Visitor

Please help!  Spotify keeps stopping for 5-10 seconds then starts playing on it own for 20-30 seconds then stops again over and over.  This really sucks!!!!

 

  • Make and model of the device(s) this is happening on.
  • OnePlus 6T
  • The Exact version of the operating system.
  • Android v10 and OxygenOS v10.3.1
  • The Exact version of Spotify.
  • Spotify v8.5.50.916
  • The Chromecast firmware version.
  • Chromecast firmware 1.42.172094
  • Are you playing via voice commands or Connect?
  •  I'm casting from the Spotify app.  Not using voice.
Visitor

Having the same issue with Spotify, when casting to two different Chromecast Audio units on the same Wifi connection. Both units are on firmware version 1.42.172094. Spotify is latest version iOS. Casting directly to the Chromecast Audio units via Spotify iOS app.

Casual Listener

TO SPOTIFY:

  • Make and model: iPhone 6s, 7, 8, and 11
  • OS: iOS 13.3.1
  • Spotify: 8.5.51.877
  • The Chromecast firmware: 1.42.172094 
  • Are you playing via voice commands or Connect? Not voice commands.

Come on Spotify! I have five iPhones and three Chromecasts. I had the problem for six months. Possibly all versions has been updated during this time. Why are you stalling by asking these questions? It really does not seem to be a highly specific problem in just a specific combination of devices.

 

I cast from several providers/apps. It all works flawlessly except for Spotify which barely works at all.

Visitor

OnePlus 6 

Android 10

Spotify 8.5.50.9

 

Doesn't really matter which device or version, tried connecting from my wife's iPhone, with a different account, from PC and from iPad. All have the same issue.