Announcements

Spotify Connect not working on multiple 3rd party devices

Status: Fixed

Recently there have been numerous reports that Spotify Connect is not working on 3rd party devices like wireless smart speakers, multiroom speakers, sound systems and receivers. 

It's either possible to connect to the speaker using the Spotify Connect picker, but songs cannot be played and playback cannot be controlled, or the speakers appear grayed out and cannot connect at all.

Hello everyone,

 

We are aware that this issue has been going on for quite some time now. Thanks to your reports and immense help in troubleshooting this, we are happy to say that this should now be fixed. The information provided from members of the community greatly helped the tech teams from Spotify. They worked together with different speaker manufacturers over the last few months in order to pinpoint what was causing this connection issue and were able to sort it out.

 

If you're still having issues playing music on your sound systems via Spotify Connect, we recommend the following:

  • Check if there are any firmware updates available for your speaker and install them.
  • Reboot your router and re-connect all devices to the network.
  • Alter your router's DNS to 8.8.8.8.

 

Don't hesitate to reach out again if the issue comes back! We'll do our best to get on it right away, so that you can enjoy your music.

Comments
Allan_AA

Premium 

Denmark

Device is I Phone X max

Operating System is 15.3.1

 

 

I have a Samsung MultiRoom system that has run without no problems for years but now it suddenly stopped a while back. Now I’ve had time to try a lot of different things like restarted speakers, reset router, clean uninstalled all apps involved, reinstalled etc etc but nothing seems to work. 
when I hit play it just doesn’t play. If I use the Samsung MultiRoom app and streams radio directly to the speaks it works fine. Just not with Spotify. 

many help what to try?

 

kindest, 

Allan

 

Kiril

Hey @Allan_AA,

 

Thanks for posting and welcome to the Community!

We understand that you're not able to enjoy your Samsung MultiRoom alongside the Spotify app. This feature is available in the Premium tier of the app and could be done via the Spotify Connect feature. In case you are not seeing your MultiRoom system as device, then you can also try the steps given in Samsung's official article here and see if following the steps there will make any difference for you. 

 

You've mentioned that you've already reinstalled the apps involved in your setup, but it could be worthwhile doing another so called clean reinstall (it has just a few extra steps) of our Spotify app to get rid of any previously cached files that might be causing trouble in the moment. See if this will shake things up and get things going for you again.
 

Hope this helps. Let us know how you get on.

Zigge

Hallo Allan

 

I have the exact same problem, with Spotify Connect and Samsung Multiroom speakers, it just won't start playing, but pauses again right away, even though I can see the speakers in the Spotify app. And as you say, it works fine with like internet radio, so the problem seems to be Spotify or Samsung that have done something with their Spotify compatibility. It worked fine for years, but then just the other week it stopped working, first on one speaker and later on all of them.

 

I exactly got it to work again the other day, but for a short time. I got a new router and reconnected the speakers and then the all worked again, but not for long, so I guess it's probably not the network/router. I'm from Denmark as well, but I guess that it's just a coincidence.

 

Hopefully we can a solution.

 

Zigge

Hello Kiril

 

Thanks for the reply, but none of it helped as I have the same problem, see the above post. 

Jeremy

Hi there @Zigge,

 

Thank you for your reply in this thread.

 

Can you confirm that you followed the steps that's provided in this article? There's some more steps to help thoroughly uninstall the app from your device, so if you haven't, we'd highly suggest it since the steps will make sure there's no old cache files causing this.

 

It would also be great if you can let us know if you have any pending OS updates?

 

On another note, there's a similar thread here. We suggest that you head over there and provide the information that's being asked by @dinomight.

 

We'll keep an eye out for your reply.

 

Take care!

Allan_AA

I've tried that several times but It still doesnt work, unfortunately. 

 

Any other suggestions to try?

 

/Allan

dinomight

Hey there @Allan_AA! Just jumping in on this since I also have a Samsung multiroom speaker and have run into similar bugginess on occasion in the past. The biggest thing that has normally helped me resolve issues like you're experiencing has been to perform a hard reset on the speaker, which refreshes the device and lets you run through the whole setup process again. I only have one speaker, so your experience might be a little different with multiple speakers and a hub. It would probably be a good idea to test your speakers one at a time before reconnecting to the hub. 

 

Also, exact methods for performing a hard reset may vary depending on your exact device. I have an M5 model, and in my case I have to perform the steps on this page, but be sure to check for specifics on your model in case it works a bit differently.

 

One other suggestion would be to try connecting from another device, such as a PC, if possible, either through the desktop app or the web player. That would at least let us know if this is limited to just your phone or Spotify as a whole within your system.

MrMEEE

Hi

 

I have the same issue... Spotify on all of my devices (3 phones, 4 tablets and in browser on pc) have stopped working with all of my 11 multiroom speakers.. The spotify clients have no problems connecting, but when press the play button, it switches quickly to the pause symbol and then back.. I even get the "pling" sound when connecting with spotify, so the connection works.. Playback from the multiroom app also works perfectly..

 

Has there been some kind of change in codec/format? Maybe you have changed to something that the multiroom speakers can't play?

 

Please help

Zigge

Hi Jeremy

 

Thank you for the reply.

 

I have tried to perform a clean reinstall of the app, but it didn't help and I also have the same problem using a computer or another phone.

 

I don't have any pending OS updates.

 

I have tried to reset the speakers and it doesn't help. 

MrMEEE

@Jeremy

 

I don't think this is related to the other issue that you refer to..

 

This is clearly something new, that apparently a lot of people are facing...