Spotify connect / Sonos skipping songs instead of playing

Thanks When I use Spotify to connect with my Sonos and press play on any track it immediately skips to the next so I can't listen to any music other than on the phone or with Bluetooth speakers.  This is forcing me to use the Sonos app (not nearly as good).  The problem used to be only on my iPhone but now my iPad has it as well.  I've uninstalled and reinstalled the app but that had no effect.

I saw someone had posted this issue 3 weeks ago and it was closed without a resolution.  Hoping you can help this time?

Hey everybody!

 

We're closing this thread as we haven't heard from you in a while. If you're still having the same issue, just give us a shout.

 

Have a great day.

Comments
FabianS_Bogota
Roadie
Status changed to: Need more info

Hey @laneandrew80!

 

It's not cool that this happens. Just to confirm, are you trying to play music from the Sonos app using Spotify? Make sure you have the latest version of each app. You could also try restarting your Internet connection to see if it makes any difference. Also, let us know what device, operating system and Spotify version you're using. We'll see what to suggest.

 

Take care!

jakehancock
Newbie

Same thing is happening to me! Spotify and Sonos software are both up to date and connected.

 

Via Sonos app, Spotify works normally.

 

But in Spotify app (preferred) whenever I play a song, it skips to a different one, and neither will actually play.

 

Very frustrating - please help!

jakehancock
Newbie

...and this is consistent for both desktop and mobile Spotify app. It will play through the phone/computer speakers, but when I choose Sonos speakers through "connect to device" menu, it's not working.

Leonardo
Roadie

Hey @jakehancock!

 

Could you try udapting your Sonos' firmware? You can do so by going here.

 

Let us know how it goes.

wlkrtxrngr
Newbie

@FabianS_Bogota@Leonardo I am having the same issue Windows 10 PC to Sonos.  The system was working fine until a week or so ago.  While playing a song on the PC as soon as you select yo connect to the sonos, it starts immediately skipping to the end of the song.  Then does the same to the next song in the play list.  It does it with both on shuffle on/off.

Spotify version: 1.0.63.617.g5aca9a2a  typically SPotify automatically loads any new versions when i open it.  It has not done that recently.  When i went to check the about for this message found that there is a new version.  Updated to new version restarted and the issue still occurred.

New Spotify version: 1.0.64.399.g4637b02a

 

Sonos plays fine through sonos controller app for same Spotify Playlist.

Sonos Controller PC version: 7.4, build: 37244160

Sonos Bridge and all Plays are on the same version.

I checked the link that @Leonardo posted above for updating Sonos Firmware.  7.4 is the latest version.

Alfredo
Roadie

Hey @wlkrtxrngr, thanks for all the info!

 

Just to confirm, are you receiving any error messages when the music starts skipping?

 

Also, do you have a different device you could try using to test things out?

 

Keep us posted.

laneandrew80
Casual Listener

I updated everything and then it worked again for 2 days but last night the exact issue returned.  Any thoughts beyond updating things again?

Alfredo
Roadie

Hey @laneandrew80, thanks for the update!

 

Could you send us your device's make and model, OS, and Spotify version numbers?

 

We'll see what we can suggest.

Julian
Moderator
Moderator
Status changed to: Closed

Hey everybody!

 

We're closing this thread as we haven't heard from you in a while. If you're still having the same issue, just give us a shout.

 

Have a great day.

Related Issues