Help Wizard

Step 1


Spotify link in Alexa app does not work






Echo dot / iPad 

Operating System

iOS 12.2 on iPad. 


My Question or Issue

I can’t work out how to get Alexa linked to my Spotify. Guidance says Alexa app/ settings / music/ link new service, which leads to a Spotify button that doesn’t do anything. Manage Services has Amazon Music and Tune in added ok, but not Spotify.


I’ve seen a few variations over past years on here on how to make this happen, but can’t find one that works. UK premium service, UK address. Someone suggested using Alexa app and About to deregister echo dot, but I can’t see a deregister option there.


For a widely offered service, it surely can’t be this difficult to link the two up. I know I can play via Bluetooth but I wanted the extras this link up offers, including voice control and not tying the sound output on a device other than Alexa up. 



Hey folks,


Thanks for your patience while we looked into this.


We've made some changes backstage which should now fix the original issue as reported by users!


You can now use the steps below to link your Spotify + Alexa accounts:

  1. First, make sure that both Spotify and the Amazon Alexa apps are on the latest versions available
  2. It's also a good idea to perform a soft reset/reboot your devices
  3. Then, log in to your Spotify account on a browser, head here and revoke access to Alexa
  4. On the Amazon Alexa app on your mobile device:
    • Tap the three lines menu on the top left > Settings > Music & Podcasts
    • Find Spotify in the list and click Enable to Use 
    • In the authorization screen, double check that you're trying to log in with the correct Spotify account and click Agree

If you're having trouble with any of the above, make sure to create a new thread in the relevant help board here.


Thanks again!


I had tried to use before but it kept redirecting me to install the app.


I logged in from laptop, unlinked my Spotify account then re linked it in my app.


All working agai,. Thanks to posters above for suggesting this 😊


Finally, a solution! 


Per the previous posts, I went to on my laptop and uninstalled the Spotify from there. I then went to the Alexa app on my iPhone and re-linked Spotify. It was seamless!


Thank you patgooch-ca, you solved the problem!






I have the same issue on Android after being prompted to change my Spotify password, despite deleting and re-installing both apps

- Spotify App Version

- Alexa App 2.2.271281.0

- Device Pixel 3 running Android 9

Ditto for me. Unlinking Spotify from my laptop at and then relinking it from the Alexa app did the trick!

Unlinking/relinking from laptop worked! Thanks!


Coincidentally also billed for my Spotify subscription today...


Finally!!!!  un-linking Spotify from the site also worked for me.  

Thank you!


Spotify 8.5.7

Alexa App 2.2.274975

iOS 12.2

Device: iPhone7


deleted and reinstalled both apps, no change.


Issue first noticed after a mandatory Spotify password reset.


Follow up; shows Alexa web app just fine. I unlikned and relinked. Now shows in app. Probably an Alexa app issue not spotify

@Guido Having the same problem with changed password. Spotify Version: Alexa Version: 2.2.274975 Device Model: Amazon Echo (?) OS Version: 637566720 Please help!
Status changed to: Under investigation



Thanks for all the examples. We've sent them over to the appropriate team that will further investigate.


There seems to be a work around posted by @patgooch-ca which you can read below this Status Update. So if you are experiencing this issue, please see if that works for you.


If it doesn't please hit +vote and leave a comment with the following:


  • Spotify version
  • Alexa app version
  • Device model
  • OS version

We'll let you know as soon as we know more.


Thanks and have a nice day!