Spotify not showing up in Waze

Status: Fixed






iPhone 8

Operating System

iOS 12

My Question or Issue

Since two Spotify updates ago, Spotify has not displayed itself in the Waze media player except for a couple of short occasions. I've deleted and redownloaded both apps, but the problem persists. The media player will confirm Spotify is synced, but will only display the simple play button, skip and back, as well as the plus in the cicle to add a song to the favorite songs playlist button. None of these function however. I have all the appropriate settings enabled. Is anyone else experiencing this or found the solution?

Hey folks,


Thanks for your patience while we looked into this issue.


We’re happy to say that this should now be fixed for everyone - just make sure your app is updated to the latest version!


Thanks! Stay awesome 🙂


Hoping somebody can help here.


Been using Spotify through Waze while about my journeys. All of a sudden yesterday when you click the small Spotify logo on the map and “resume playing” to continue listening through Waze, it opened Spotify and played then returned to Waze as normal, but the play, forward, back and album was all greyed out? I have to switch apps back to Spotify to skip a song or anything else.


Both apps are up to date, phone is up to date. Tried disconnecting Spotify from Waze and reconnecting but still same issue. Any other suggestions? Cheers in advance!


I have exactly the same problem. I have de-authorised both apps from each other and set them up again. It worked for 1 trip and then the bug  returned. It was working well up until a few weeks ago. 

Status changed to: Need more info

Hey folks,


We’re receiving reports that Spotify on Waze is not working as expected.

First, we'd recommend trying a clean reinstall of the app on your device by following the steps here.

If after that you’re still experiencing the issue, could you provide us with the following info:

  • device + OS version
  • exact Spotify version
  • exact Waze version
  • a screenshot showing Spotify not working?

Once we have that, we'll pass it on to the relevant team, who will look further into it.



Hi, this is iOS 13 on an iPhone 8.


screenshot was already posted in OP, but I will attach another.






iPhone X IOS 13

Spotify ver 8.5.23

Waze ver 4.55.1




For me its


iPhone XS Max iOS 13




This also happened on the final release of iOS 12 and has also been happening for now over a month. 


Iphone 6s iOS 13




It's been a while now that I have not been able to use them together


Reinstalled both apps. Still having the same issue as everyone else. Happens both when navigation is on and off. 

iPhone X 

iOS 13.0 (was having issues on previous versions too)






Today my apps have started talking to each other. Same app versions, no updates etc.


The only thing that's changed is I have paired my phone with a different cars Bluetooth system. Just an observation that may lead to a fix, not had chance to try the original blue tooth device to confirm this. 


That's interesting, I don't use it with Bluetooth, just on the mobile device so I'm not sure on that. 

hopefully a fix soon!