Announcements

Spotify starts playing automatically when locking my iPhone

 

Plan

Premium

 

Country

The Netherlands

 

Device

iPhone X

 

Operating System

iOS

 

My Question or Issue

Hi!! Whenever I pause my music and lock my phone, it starts playing automatically. I have this issue for about 2 weeks now. How to solve this? 

Hey there folks,

 

We really appreciate all your reports and patience thus far!

 

We've done some magic backstage and this should be fixed in the latest version of the app.

 

If you're having troubles, first make sure that the app is rocking the latest version available. You can also try a quick reinstall

 

If that doesn't do the trick, don't hesitate to let us know by starting a new thread in the related Help Board. We'll be happy to lend a hand 🙂

 

Have a lovely day!

Comments
Newbie

SomeCake, do you ever use Bluetooth devices? 

 

I find the issue does not occur when actually using the Bluetooth device, but shortly after it has been disconnected.

Casual Listener

Each time the issue started on my iPhone was just after disconnecting it from my car's bluetooth.

Regular

Same here! Very annoying, also embarrassing when it happens at the office and you were listening to Grindcore. Please fix!

Music Fan

same here, iPhone xs ios 12.2

Newbie

Same here. I uninstalled the app and it still does it after a fresh install.

Newbie

I have the exact same problem. iPhone XS.

 

It doesn't happen ALL the time, but 99% of the time. Doing a fresh reinstall and restarting the phone seems to temporarily fix it for a few minutes.

 

Currently I need to force-kill (swipe away) the app, which is both annoying and not intuitive. 

Newbie

Same issue here. If I'm playing music and stop it, it starts playing again when my phone is locked or wakes up. 

 

IPhone X

IOS 12.2

App version 8.5.0

 

Casual Listener

Same problem but with only spotify app because i tried with iTunes it doesn’t happen but as i turn on spotify turn on music then pause and lock it starts playing by itself. 

Newbie

I also have the issue on an XS Max wifh 12.2 and can confirm the issue appears after I’ve disconnected from my car’s Bluetooth.

 

Reinstalling the app is not a fix and the problem is easy to reproduce.  Hopefully the devs get this knocked out, especially since it is reproducible, ASAP.

Related Issues