Help Wizard

Step 1

NEXT STEP

Spotify stops playing after an ad

We've received reports that Spotify pauses after an ad and the playback cannot be resumed. This seems to affect multiple platforms including desktop, mobile, and TV.

 

The behavior is currently being investigated.

Hey folks,

 

We just wanted to let you know that the right folks are looking into this.

 

We're not able to provide an exact timeline for a fix, but we'd recommend always keeping your Spotify app up to date to ensure you're on the latest version.

 

Thanks again!

Top Answer
MihailY
Moderator

Hey everyone,

 

Thank you again for sharing the requested details.

 

All reports have been forwarded to the team investigating this, however, they're still having difficulties tracing the root cause and need your help. 

 

For this you'll just need to confirm you're willing to participate and share your device details if you haven't already. If you have, just share your current Spotify app version so we have the most up-to-date info.

 

Once you've done so, we'll post a confirmation in the thread that your account is being monitored by the devs and you'll need to reproduce the issue again giving us the timestamp of its last occurrence.

 

Hopefully, this will allow the team to spot the error and fix it.

 

Looking forward to your replies 🙏

Comments
guinogo

Plan

Free

Country

Spain

Device

iPhone 10 - SONOS ONE S.L

Operating System

iOS 

 

My Question or Issue

Every time I play Music over my Sonos speaker and the commercials started, it stops the playback and you can not continue using it. You must then come back to your iphone device and restart the music playlist. That happend since 2 months ago approx.  

 

baventjr

No entries were in my hosts file.

baventjr

Tried Clearing my cache with no luck also.

 

Klaywiki

Amazon firestick.  Happening every time I try to use the app on firestick.  Start a Playlist and as soon as the first advertisement hits I have to restart.  App version 1.78.11 on firestick.  No available updates that I can see.

DS-SCF-UK

Same Issue - Despite using Spotify previously without Issue had to abandon using Spotify on my Echo Devices over Christmas and use other Streaming Sources since it was :

Repeatedly Freezing after adverts - Pressing Pause / Play on Echo Show 5 (3rd Gen) Devices had no effect (Unresponsive)

After Playing Advert Echo Show displays the next scheduled Track but does not start and Screen unresponsive.

Pressing Skip Forward eventually restored play missing the Track due to play (ie the Track after the next listed to Play)

Freezing occurs after different adverts for both Third Party's & Spotify's own content promotional adverts

Deleting and Re-loading the Alexa Spotify Skill has no effect with the issue still present.

 

Disappointing to find that this is still an ongoing recurring Issue after being reported well over a year ago and reportedly escalated to Spotify's Technical Team back in Aug 23

 

Plan - Free

Country - UK

Devices - Echo Alexa (Multi-Device & Multiroom Playback)

Activation - Alexa Spotify Skill

Content Affected - All Playlists

Alexa App v 24193910

Android 12

 

 

baventjr

Tried logging out and back in with no help.

Running Spotify for Windows (64 bit)
1.2.26.1187.g36b715a1

This only started happening in the past few months.

 

nsu1997

Hello, my free Spotify account is stuck on a Peloton ad. Both the Windows PC app and my Android app are stuck on the same ad. I cleared the cache, deleted the data, logged out and logged back in, uninstalled the app on both devices, restarted both devices, attempted to play other songs and playlists, everything. The same 30-second completed Peloton ad shows up and will not move beyond it.

CammelloIta

Same problem on my Samsung smart TV, after 1 or 2 ads it just stops and doest move, the only way I found out to fix it momentarily is to connect my phone, close the application so it does not charge immediately the ads and click start on the player soon you see it say a song name so it start the song and not the ads, but after a while when an ads appear it just block again

Bruce2666

Everytime to listen to Spotify music and the first few songs work then I get an ad which refuses to play and stops my music altogether. It does the same on Alexa. 

wight1984

I'm also getting this problem, but only when playing through echo devices