Help Wizard

Step 1


Spotify stuck on logo screen on iOS

We've received reports from iPhone users running iOS 16.3 and 16.3.1 that the Spotify app won't load past the logo screen. This is being investigated.

Hey folks,


We really appreciate your understanding and cooperation while our teams were working on a fix! 


We’re happy to say that this should now be fixed for everyone! Just make sure your app is updated to the latest version.


If you're still having trouble, make sure to post a new thread in the relevant help board here.




Tried the sequence you recommended. Didn’t fix anything the first time. Then I tried again and it worked the second time. Weird.


Yeah - not sure how to react to this "special" feature either 😄

I have an IPhone and Spotify doesn't open, I click on it and the app just stays black with the logo in the middle. It's been like that since last week. I tried everything I saw, as: reinstall, turn off the phone, clean the RAM, etc.
It works fine on the desktop version

I also have this problem, for a week or so now. I have iOS 16.0.3, on an IPhone X, last Spotify version on the App Store (8.8.5) and I didn't do anything new or different from last week (didn't update the software or change any settings)


Hi folks,


We'd like to investigate further. If the issue persists even after uninstalling the app > restarting your iPhone > reinstalling Spotify, please share a short screen recording which showcases the app's behavior so we can have a direct look at what's happening on your end.




Usually, if Spotify stays on the logo on mobile, it can't connect to Spotify's servers.

Have you tried another network? Do you have Spotify excluded from any VPNs?


Hi, yes I did try another network, same issue. And no, I don't have Spotify excluded from any VPNs


Is your Spotify and iOS up to date?

I have updated my iPhone to the new update and now my Spotify will not work. Has not worked for two days. Used multiple WiFi connections and nothing is helping.

I finally was able to resolve the issue after many attempts of uninstalling, restarting, forcing logout, etc.. This originally happened the day after I updated my phone to iOS 16.3, but it also coincided with the day of the Spotify outages last week. So not entirely sure what was the main cause.