Static when playing from vizio sound bar

PLEASE HELP! Having a party tomorrow. We use our iphone 7 to log on to spotify and play the music via googlecast built into our Vizio soundbar. Certain sounds play slow and or have TERRIBLE static. Please please help!

Hey everone, 

 

Good news! It looks like the latest VIZIO soundbar firmware update has solved this issue.

 

 

Thanks for bearing with us :)

Related Issues

Comments
CroatianChad
Newbie

Smart cast is sooo glichy . 

 

Hisense 4KUHD HDR k8,

Vizio 45" slim bar Two satellites on stands w big thin sub 5.1 w cast

 

iphone 7+ 

greg2313
Newbie

Vizio have posted the firmware update on their site with a specific note: `Improvements to Spotify Audio Quality when casting`

 

https://support.vizio.com/s/article/ka51a000000L37M/Firmware-Information-3115?language=en_US

cnettles
Casual Listener
Now THIS could mean we are FINALLY getting somewhere! Thx!


Marcusmoeller
Newbie

I "tried" to do the update, It didn't update it and I'm still have the same issue. Anyways. It looks like that's an older version anyways..

cnettles
Casual Listener
Aw that sux. Thought we were getting somewhere. I haven't been able to try it. We'll see...


greg2313
Newbie

Vizio roll out updates over a few weeks, if you want to force it you can download it to a USB stick and manually update. 

Marcusmoeller
Newbie

Now my soundbar won't connect to my phone via Bluetooth after trying and failing to update 

cnettles
Casual Listener
Wow. Terrible


user-removed
Not applicable

 

Hello everyone. I can confirm beyond the shadow of a doubt that the problem lies with Vizio's latest firmware update (1036). I have the Vizio SB3851-D0 soundbar. Prior to the update, it worked nicely. I was excited for the update because it would allow grouping within the Google Home app (so multiple speakers/cast devices could be played at once). I woke up the other day and noticed the firmware got updated to 1036, so naturally I tried to cast. Nothing. I have already done everything including doing a firmware reset. This has affected all of my casting apps including when I try to cast from my laptop. iPhones, Androids, etc; nothing works. I reached out to Vizio and they were very responsive up until I mentioned the firmware update. Then all communications stopped. We need to put pressure on Vizio to release a fix for this. Spotify is in no way responsible for this.

user-removed
Not applicable

Oh, I also tried this at my local retailer; all of them have the problem. It prompted them to unplug all their Vizio smartcast devices.