The device I have at home is visible and controllable in other places and devices.

Hi, 

I'm not sure it is a bug, but it's so strange.

At home I have device Pioneer Amplituner (with home cinema speakers) with Spotify Connect and it is set to wake up by network. Everything works fine. But now I'm at work - at different place at different address with completely different network.

Here when I turn on Spotify App on desktop and mobile I still see Pioneer device from home and... I can connect to it and control music, volume (which is dangerous due to ability to set volume to max). Recently I tried this and my wife was scared because during watching TV a Spotify started to play loudly.

It is normal? Erenow there wasn't such option.

Hey @restful! Thanks for your report!

 

You can control your devices at home once they're setup with your Spotify account. You can turn this off on your iOS device in 'Your Library > Settings (top-right) > Devices'. Let me know how you get on! 🙂

 

Have a great day!

 

P.S.: Thanks @Jeff_C, for your troubleshooting here! 🙂

Status: Not An Issue
0 Likes
Comments
Jeff_C
Newbie

IIRC there is a setting (in the web settings page of your account - not within the app settings itself) which allows control over the internet. I suggest you look for and disable that setting. If that does not work wait for further help.

restful
Casual Listener

I can't find such setting. There is "Offline devices" but home device isn't there. To be sure I removed all. I think it is not what we talking about.

Jeff_C
Newbie

I do remember a 'web page - account specific' setting for something like this but I have just checked and it is no longer there. But there is such a setting now in the Spotify app itself. Navigate to 'Settings' then click 'Advanced Settings' and you should see an option "Allow Spotify to be opened from the Web". IIRC it defaults to 'on' but I changed the setting for my account to 'off'. 

Hubo
Rock Star 16
Rock Star 16
Status changed to: Not An Issue

Hey @restful! Thanks for your report!

 

You can control your devices at home once they're setup with your Spotify account. You can turn this off on your iOS device in 'Your Library > Settings (top-right) > Devices'. Let me know how you get on! 🙂

 

Have a great day!

 

P.S.: Thanks @Jeff_C, for your troubleshooting here! 🙂

restful
Casual Listener

Finally I found such setting: Library > Settings > Devices > Show local devices only.

Thank you guys for your help.

Related Issues