Track Information On Car Display Is Out Of Sync

Hi

I'm streaming music from the spotify app on my android phone via bluetooth to my VW car. The sound is streaming just fine and i can change between tracks on the stearing buttons etc. The track information is shown on the screen in the car.

But the problem is that after the first track i selected on the phone, the track information is delayed with previous track information, so the track sound and track information is out of sync. The track sound playing in the car is the track shown on my phone. But wrong track information is shown in the car. Selecting a track on the app again wil send the correct track information to the car again, but then continues to get out of sync.

Anyone have a solution to this ?

 

I could say that the track information was shown correct 3 months ago when i used my old Sony Z3 compact Android 6.0 phone with the Spotify app. But on my new Sony - Android 8.0 phone i have this anoying problem.

Hey all,

 

Thanks for getting back in touch!

 

We're not able to provide an exact timeline for a fix, but we really appreciate you letting us know about this. We're always working to make Spotify a better experience. We'd recommend keeping an eye out for updates to the app.

 

Have a nice day.

Related Issues

Comments
schou1984
Casual Listener

well now Android Auto is not available in my country so I guess this would not help ;-)

khepri84
Newbie

I have recently received an update to Android 8 from Huawei for my P9lite and Spotify stopped to properly update the track info in my car.

 

When I hit play, the first song's name is correct but then the display continues to show that name, without updating it on a new track.

 

Looking at the forum I have seen that this is a well known problem and that it lasts since several months. 

 

Since I use Spotify mostly on my car, this looks as a major problem to me and I don't understand how this has not been solved in the last 7-8 months. 

 

Considering that I am paying a monthly fee for the service I would expect a quick fix for this kind of problems that is well known and it is affecting several users. 

 

 

 

Keatrix
Newbie

Still no update after so many time.

I got a Subaru Impreza Sport 2016 using BT with Spotify premium on Android 8.0... but after the first track nothing happens.

Tried everything, the song still play but the data is not showing the right one anymore.

 

khepri84
Newbie

Yep, same here and since I cannot believe that it would be such a difficult fix, I am starting to think that they simply don't care.

-ppat_gwjfod
Newbie

Same here... The name of the song is delayed.

Moderator
Moderator

Hey folks, 

 

Thanks for getting in touch about this, and sorry for the delayed response!

Could you try the following troubleshooting steps:

Could you also check to see if the issue persists when you put Spotify in offline mode?

 

Keep us posted,

 

P

schou1984
Casual Listener

Hi Peter

 

THanks for your reply.

 

I cant really reinstall the Spotify as it is installed on my Sony phone as default. But I can deactivate it and activate it again as from factory settings, I have tried this, it didnt help at all.

 

Also tried the unparing and pairing again - didnt help either.

 

I even tried to reset my phone to factory settings, a total reinstallation of the whole OS. That didnt help either.

 

My radio has the latest firmare, I checked this with volkswagen.

 

/J

Bigslick202
Newbie

My steps to correct this problem. 

 

1. Restricted my phone (Note 8) from putting Spotify to sleep and leave on in background

2. Logged out and closed Spotify

3. Un-paired my phone from my device (car radio) 

4. Re-paired my phone and device

5. Logged back into Spotify

Voila! 

khepri84
Newbie

Hello Peter,  thanks for the answer. 

 

I have already tried to uninstall/reinstall Spotify and to unpair/pair my phone with no result.

 

I have not tried yet to use Spotify on the car while in offline mode.. I will try and I will let you know.

Keatrix
Newbie

Hi Peter,

 

Thanks for the reply, actually i tried all you told us and nothing work, i did try alk of this before too.

My car is a Subaru Impreza 2016, the radio is updated to the latest update and the track info are showing when im using google play music or any other type of player, the only two not working are Spotify premium and Amazon Music, but i like Spotify better so i really want to find a way to solve this problem.

Thanks,