Unable to find chromecast audio

Status: Closed

Since you are always closing issues after asking the same questions again and again, please see prior posts.

Spotify for android doesn't always find the chromecast device, other applications ALWAYS finds it. Restarting spotify helps (sometimes a force stop is needed). This is really annoying and clearly a bug.

 

https://community.spotify.com/t5/Ongoing-Issues/Unable-to-find-chromecast-devices/idc-p/1905264

https://community.spotify.com/t5/Ongoing-Issues/Unable-to-find-chromecast-device/idc-p/2014590

 

Android version is stated in one of the prior posts.

I have restarted, and also changed, the access point.

The problem occurs on two different brands of android phones.

I have no offline playlists.

Removing and installing spotify again doesn't solve the problem.

 

Please stop trying to delay this issue by asking the same questions again - I do not always have time to answer them daily.

Hey!

As we haven't heard anything back, we’re going to close this for now 🙂

/L

Comments
Erika

Thanks @otie and @jthole!

 

We want to gather more info. When was the last time that you were able to use Chromecast with Spotify as you usually do? Also, is your Chromecast Audio set up a single device or a multi-device home set up?

 

Keep us on the loop. 

 

jthole

@Erika Not sure, since I have been abroad for a while. This summer, it was still working most of the time (but not always).

 

I have two devices, but they are not grouped. Both devices run the same, and latest, firmware.

 

I never have the situation that I can see one of the devices only. It's all or nothing.

jthole

@ErikaThis morning I had a different issue, which may be related. Yesterday night I had the phone connected to Bluetooth (in the car). When I wanted to play music this morning, I did see the Chromecast Audio devices, but Spotify could not connect to them. I tried casting audio using Google Home, and that worked perfectly.

 

After I restarted Spotify (force stop - start app again), I could connect without any problem. It almost looks like Spotify does not like switching devices (e.g. from phone over Bluetooth to Chromecast) or networks (from cell to wifi).

thompouce

Having the same problem. Restarting spotify once (killing it in the recent apps) usually doesn't work. However, when I restart the app three times it consistently manages to connect afterwards. Other apps work without problems. Clearly, this is a problem with the app rather than the Chromecast. Just add a refresh button or something, especially since restarting the app works.

Mara_F

Thanks for the info guys. 

 

There's a new version of Spotify (8.4.22), could you try downloading it and letting us know if you're having the same issue? If so, let us know so we can report it to the right folks. 

 

Take care. 

thompouce

Thanks for getting back to us. In the Google Play store I can see that I have been on 8.4.22.857 for about a week now. Unfortunately, the problem has persisted.

jthole
  • Same here; no change in behavior.
Mara_F

Hey guys, us again! 

 

We'd like to report this to the right folks, but we've only received a reply from 2 users. We'd like to know if more users are having the same issue until this day after reinstalling the app. 

 

It would be super helpful.

otie

Problem still exists today, version 8.4.25.771

TB29
I've also not see any improvment.