Help Wizard

Step 1


Unable to find chromecast devices

Spotify on Android doesn't always find the chromecast device. It usually helps killing the application (force stop) and restarting, but not always. Sometimes restarting the phone is the only way to go. Google home app always finds the chromecast device.


Using Android 7.1.1 on Oneplus 3 and Spotify This has been around for quite some time during several versions and is quite annoying.

Hey everybody!


We're closing this thread as we haven't heard from you in a while. If you're still having the same issue, just give us a shout.


All the best 🙂

Status changed to: Need more info

Hey @otie! Welcome to the Spotify Community!


That's not cool! Could you give these steps a try? Those should help here. If that didn't help, could you let me know your Spotify, OS and Chromecast versions?

Thanks, take care! 🙂


Well, thoose steps are when it is not working.

It works sometimes, and google home app always find it, and other applications always works. As I said, a reboot or killing spotify and starting it again usually helps. The problem is only with spotify, not other applications.


Spotify and OS versions are stated in first post.

Chromecast audio, with cast firmware version: 1.25.90308


Thanks for the info, @otie.


Could you let us know if this happens with any other devices you're connecting to your Chromecast? If you'd like, it might help to restart your wireless router.


Also, it wouldn't hurt to give Spotify a clean reinstall with these steps. Give that one a shot and let us know if the app behaves any differently.


Keep us posted 🙂


Cleaned data, reinstalled Spotify, changed access point to another brand. Same result.


The same thing happens with a Sony Xperia X Compact.


Thanks for keeping us posted, @otie!


Just to make sure, have you noticed if this happens after you lock your device? If so, we'd suggest turning off battery optimization for Spotify on your device. To do so, just follow the steps here.


Let us know how it goes.  


Not OP, but same issue here even after doing all the steps, including turning off battery optimization. I don't have this issue with Google Play Music or Tidal for example.

EDIT: OnePlus 3T with Android 7.1.1


Thanks for all the info!


Let's get to the bottom of this. Could you let us know a bit more about your Chromecast set up? Is it just one device you're using or is it a group of devices linked to the same network?


Also, do you have a different Chromecast device you could try using? We'll see what we can suggest.


Keep us posted.


I have altogether 3 Chromecast devices (1x Chromecast Audio, 1x Chromcast 1st Gen, 1x Chromecast 2nd Gen) linked to one network (with 2 Access Points). 
They appear and disappear altogether, so most of the time I'm seeing 0 devices and after for example restarting the phone all 3. All devices are up-to-date, the Spotify app too.


Only one device, unfortenately that is the only one I got access to.




@saebbe We suggest checking out this post since it could be more relevant to the issue you're having.


@otie Just to confirm, is your Android system rooted? Also, have you tried restarting your internet router?


Keep us posted.