Announcements

Unable to find chromecast devices

Status: Fixed

I sometimes have issues setting the spotify app to play on my chromecast devices. 

 

The app won't list the chromecast devices in the list "connect ot devices", so I can't select them.

It does allow me to select the app on my tablet, which is also in the same wifi-network.

 

Things I noticed:

  •  It might happen when my phone has been disconnected from my wifi for some time. But it won't list them when I connect to the wifi, even after 30 minutes.
  • Starting the application on my computer almost instantly lists it as an option on my phone.
  • The Google Home app lists the ChromeCast devices without a problem.
  • Going into android settings and forcing the app to stop, immediatly starting it again will list the chromecast devices and allows me to use them, but this is highly annoying.

 Perhaps the app needs an option "search for new devices on network" or something like that.

 

I'm on Android 7.1 using the latest version. (checked in the play store).

Hey folks,

 

Thanks for bearing with us.

This should be fixed with the latest version of Spotify on Android. 

Just head to the Play Store and search for Spotify. If you haven't done it already, you should see the option to update. 

 

All the best,

Chris

Comments
Pól

I have a similar issue on with my Mac.  The spotify app won't see the chromecast device wifi when I scan. However my two android phones do and if I then connect using either phone, the Mac app then reports that spotify is connected via the other device and allows the mac app to take over. It's really frustrating that I have to connect a phone for the Mac to be able to see it. Why is the Mac blind on its own?:
OSX 10.10.5; Spotify 1.0.53.758.gde3fc4b2; Chromecast: 1.23.84839

DoppyNL

I'm aware the application on a computer won't see the chromecast, you need the app on the phone to do just that. This seems to be because of a lack of API on the computer to find the chromecast devices (as the phone app hooks into the available API's on the phone).

 

My problem is solely focused on not being able to find the chromecast devices on my Android phone. As I posted, when it doesn't see them I can force close the app and restart it and it will see them. What I do on my computer has no effect on this.

Lloyd4

I have the same issue. It started maybe one or two weeks ago. Thanks for the info about force closing the app. Before I had to restart the phone to make it work.

Phone: Galaxy S6 edge plus

OS: Android 6.0.1

Spotify version: 8.4.0.539

Lloyd

MonicaM_Bogota
Status changed to: Need more info

Hi, @DoppyNL@Lloyd4@Pól!

 

Welcome to the Spotify Community.

 

Do you remember if this started happening after a specific update or event? Also, can you check the steps here for us? 

 

Let us know how it goes. 

Pól

Hi Monica - The OP @DoppyNL, and @Lloyd4's issues are slightly different to mine.
Indeed I see from the steps link you shared that it states:

"It’s currently not possible to discover a Chromecast device from the desktop app. Use a mobile/tablet to discover and launch Spotify on Chromecast. Once running Spotify Connect can be used to control playback from any device, including desktop"

I've found the workaround for this;  If I open the Spotify Web Player in chrome browser I can cast the tab as I can any web page. The desktop app then shows "LISTENING ON @Spotify Web Player"  under "Devices" The desktop app of course  allows me to navigate my playlists and  folders whereas the Spotify Web Player is limited - So my particular problem is solved, sort of.

@DoppyNL, and @Lloyd4's issues still stand however.

ZullyB

Thanks for the info, guys. 

 

Have you tried to use another device to connect to Chromecast? Also, can you try to reinstall the app? Just follow these steps.

 

Keep us posted 🙂

DoppyNL

Hy ZullyB,

 

I've had the same issue with my previous phone. A Google Nexus 5 (Android 6).

I've also have this problem on a tablet (Android 6).

My new phone was new out of the box, so I already installed the app from scratch there. Also, stopping+restarting the app already solves it.

 

All ChromeCast devices are running the latest firmware version (they update automatically).

I've got 3 chromecast devices in my network (2 audio; 1 video); The audio ones are also in a group. None of the chromecast devices show up in the list when I have the problem. After I stop the app and restart it I see all 3 and the created group as expected.

 

I've got a feeling that the Spotify app is simply unwilling to refresh the list of nearby devices or there is no sensible refresh device list mechanism.

A "refresh devices" button on the screen where you can select a device could be usefull. (allthough you can only get there when a device is detected!)

It might also be handy the app automatically refreshes the device list when "app is in foreground (user is interacting) AND wifi-connection is different since last refresh (either a different network or it was disconnected)"

  

I don't know about a specific event or time when the problem started. It is happening for a couple of months at least, I figured it was a silly bug that would be fixed after some time, but so far it hasn't.

Aimee_T

Thanks for letting us know @DoppyNL!

 

Can you let us know the exact Spotify version you're using in your devices? Remember that all your devices must be connected to the same WiFi network as your Chromecast.

 

Take care 🙂

Lloyd4

Hi again

 

For the last few days my Spotify app has been back to normal. No more problems finding the Chromecast Audio.

 

I didn't do anything so maybe an update fixed it? Spotify was automatically updated this week to 8.4.1.846

 

When I had the problem I went through the checklist mentioned above with no luck.

 

Best regards Lloyd

DoppyNL

The current version on my phone is "8.4.1.846 armV7". It has been updated 2 days ago on my Phone according to Google Play. I haven't used it on my chromecast the last 2 days, so I'm unsure if this version still has the problem.

 

The problem happened for me while I'm on the same network. The Google Home app showed the ChromeCast without any problem in those cases.

 

It did pick them ChromeCasts up quite quickly just now when I connected to the wifi (I had wifi disabled).

 

I will post back when I see the problem again or in a couple of days, I'll see if the new version has any effect.

Env: prod