Unable to play anything on the Desktop player

Plan

Premium

Country

Singapore

Device

Windows Desktop (custom build)

Operating System

Windows 10

 

My Question or Issue

I was playing music on my Spotify Desktop app when it suddenly cut out by itself. I tried playing back the same playlist, but it just quickly skips through the songs one by one and stops playing altogether.


I hardly had issues playing songs on the app before in the past (Been using Spotify on this computer for >4 years).

 

What can I do to get it playing again?

 

I've tried the following:

- Restarted computer

- Soft reboot of computer

- Uninstalled and reinstalled Spotify desktop (Both downloaded and the one on Microsoft Store)

- Deleted all files I could find associated with Spotify when uninstalling (including the ones under ProgramData and AppData/Roaming)

- Updated all sound drivers

- Tried playing it on the web player (it works on the web)

- Played different playlists, downloaded and non downloaded, random songs.

- Changed streaming quality between Automatic, Normal, High, and Very High.

- Disabled hardware acceleration.

- Changed audio output device.

- Logged out and back in.

- Logged into a different account, it also doesn't work.

Hey folks,

Thanks again for reporting this issue to us.

We’ve passed your info on to the relevant team, who are currently looking into it.

If you’re experiencing this issue, make sure to add your + VOTE and try the following steps:

  • Perform a clean reinstall of the app.
  • Make sure the hosts files on the device doesn't have any entries with 'Spotify'. (steps here)
  • Update your sound drivers (If your device has multiple sound cards install/update the drivers for each card).
  • Unplug or disconnect any third-party peripherals/audio devices (e.g. DJ mixing controllers, USB headsets, digital-to-analog converters) to see if that makes a difference.
  • If you have any DJ apps/software for mixing or creating tunes, try disabling the option to exclusively use a specific sound card.
  • Run the app as administrator

You might also want to try out the solutions suggested by @nikcster and @iza46d here or if you have an Asus Xonar soundcard, check out the workaround by @Virmiculum here.

 

Thanks! We’ll keep you posted and let you know as soon as we have any updates on this.

Related Issues

Comments
Casual Listener

Same here.

Moderator
Moderator

Hey there @eugenecys and @spocken77,

 

Thanks for reaching out to us about this - we'll be glad to help you out here.
 

It's good that you tried all the troubleshooting steps you listed as this will help us find where this issue originates from. We also suggest checking your host files since this can sometimes cause playback issues with the desktop app. Check out the steps described here on how to manage your host files. 

 

Observing the same issue after logging in to a different account on the same device could mean the issue is device-related. If you have this possibility, we suggest logging in to your Spotify account on another device just to check if the same happens.


Hope this helps. Let us know how it goes.  

Casual Listener

I checked the host file - all the entries there are definitely unrelated, plus it hasn't been modified in the last 4 years, so it wouldn't be the cause now.

 

I tried the same account on other devices, it works there, so it's definitely due only on this device. 

Casual Listener
I have no entries in the hosts file. I use the desktop application every day and it has been working just fine until now. The iPhone app works just fine, with the same account. I am also able to change songs with the desktop application while playing the audio on my iPhone. However, if I switch output to my desktop, it just skips all songs.
Casual Listener
Clean reinstall didn't help either.
Moderator
Moderator

Hey @eugenecys and @spocken77,

 

Thanks for keeping us in the loop.

 

In case you folks experience this specifically on a PC it might be also worth checking how the device connects to the network you're using. Make sure to restart your router or modem and see how it goes. Even if it's happening with your downloaded tracks as well, a possible connectivity issue might affect the playback of offline contents.  

 

It's also a good idea to test if you observe the same under a different network if you have the possibility. In case it works with another connection, it's best to contact the service provider of the original network for more information. For example, some shared or public networks (e.g. schools/work/office) might restrict access to certain services, which would explain what happened here.
 

Hope you'll find this info useful. Keep us posted.   

Casual Listener

@Ivan

 

Restarting the router didn't help. I have also tried another DNS server in the network settings. The web player works fine on the same desktop, so I don't think this is network related.

Please, take a look at all other threads about similar issues that seem to have occurred recently.

https://community.spotify.com/t5/Desktop-Windows/Spotify-desktop-app-windows-10-continuously-skippin...

https://community.spotify.com/t5/Desktop-Windows/Spotify-skips-every-song-instantly/td-p/4982335

https://community.spotify.com/t5/Desktop-Windows/Can-t-play-music-on-desktop/td-p/4982236

Newbie

The same click on a playlist/radio station/album it justs cycles through the tracks without playing. I have tried all the above, but to no avail, I will add that other streaming services are working ok.

 

Casual Listener

Restarting the router, the network didn't work. My PC has been using the same network and same local IP address in the last few years, so again, nothing has changed about the network either.

 

Spotify on other devices connected to the same network works.

Casual Listener

Same here. All of a sudden it just stopped working. Have already done basic troubleshooting. Host file modification isn't a good suggestion as no one should be modifying hostfile. Reboot didn't help. All the odd suggestions like changing output and so on don't work or don't apply. Wiped Spotify and re-installed. Verified there are no network issues and nothing being blocked. Disabled AV just in case. Nothing is working. Everything inside the player is working, it is just playing songs that do not work. I can even start a session on my phone and control it via the desktop app. And interesting how there are others who have the issue all starting at the same time. Nothing has changed in any of our environments it sounds like. I know nothing has changed on my side for several weeks and it was working after that.