Help Wizard

Step 1


Voice search on Android doesn't play songs (Google Assistant AND Google Now)

From a few months ago, playing songs through google now or google assistant does not work.
You can say "play [Artist name] on Spotify" and it's going to play it, you can also say "play [Album name] on Spotify" and it's going to play it, but if you use "play [song name] on spotify" it's just going to open the Spotify app and stop there, it won't search for the song and play it like it used to.


As far as I can tell, Google Now/Assistant are sending correct intents to the Spotify app, but the app is not interpreting it correctly.

I am attaching the screenshot from the Google Now app as well.


I have confirmed the issue on Samsung Galaxy Note 4 running Marshmallow, as well as Xiaomi Redmi Note 3, Samsung Galaxy S4 and LG G5.


This might not seem like a big problem but it really is, inability to play songs without typing while driving, running or doing whatever is a real problem, and what makes it even worse is it was working without a problem in the past.

It's making me reconsider my music streaming service, and I am a premium user.


I'm available for any more information you may need.




Hey guys! 


It seems we didn't receive a reply. We're setting this as "Closed" in the meantime. 

Feel free to give us a shout if the issue persists.
Happy Holidays 🙂 

I confirm having the same problem as described above. HTC 10 android 6.0.1, Spotify Premium arm v7 

Status changed to: Closed

Hey @ljuborados and @indie_youth!


Thanks for letting us know about this. Can you recall the Spotify version that used to function with these voice commands to play specific songs?


You could also try a clean reinstall with these steps to see if it makes any difference.


Keep us posted.


I'm having the same issue. My device is OnePlus 2 and I'm using the latest version of Spotify.


Google Now detects correctly which song I want to play but only opens the Spotify app without playing that song.


I have the same issue on a Google Pixel with newest 7.1 update and newest version of Spotify installed. I tried a clean install and it didn't resolve the problem.


@FabianS_Bogota, full reinstall with cleaning cache and data didn't help.

I can't recall what was the old version but I'll check if I have it installed on any of my old phones and let you know!


@FabianS_Bogota unfortunately I couldn't find the version on which the feature worked.


Reporting the same issue; using google assistant on Google pixel, running stock Android 7.1. Spotify version is: armV7. Just some notes about the issue: using the command "play [song] by [artist] does occasionally work, but generally when it does work, it is when Spotify is either not open previously, or it is the first play request after opening. Also, when Spotify is already open, requesting a song to play that is already open and paused in Spotify always appears to work. It carries the request through by playing the song from the beginning. However this is of course a rather pointless command that would never be used.


Google Pixel XL here, vanilla Android Nougat 7.0, no root, using Google assistant. Have tried reinstalling spotify and I still encounter the same problem. This issue has been around for at least three months. I'm upset that this has had multiple support tickets put in by many users and there have been multiple bug fixes, UI updates, and security patches for spotify while this bug exists and yet this glaring issue has still not been resolved. 


Am confirming I am the exact same issue as everyone has described here. I'm using a Samsung galaxy 7 with the latest os and cannot get google now to properly control Spotify, even with clean install and clear cache.  Makes it difficult to use while driving, however, Google music works perfectly fine with Google now. Glad to see I'm not the only one, and I hope we at least get a response soon. 


@FabianS_Bogota any updates?

Thanks in advance.