Announcements

Volume control doesn't work with Sonos

Plan

Free/Premium

Country

 

Device iPhone 7

(iPhone 8, Samsung Galaxy 9, Macbook Pro late 2016)

Operating System

(iOS 10, Android Oreo, Windows 10,etc.) iOS 12.3

 

My Question or Issue

This problem started only recently. Despite being able to control the Sonos volume from the Sonos app slider, I can't use the Spotify slider to control it accurately. It is delayed and then slides back and forth on its own, fluctuating the sound. I can't use the hardware volume control for either Spotify or Sonos. This happens whether I have the Spotify app open only or both the Spotify and Sonos apps.

THIS HAPPENS ONLY WHEN I AM PLAYING SPOTIFY THROUGH SONOS. If playing Spotify alone on my iPhone it works fine, with either the app or hardware volume controls. Same with using only Sonos.

I have the proper settings on for integrating Spotify and Sonos. Also to allow hardware volume control through my phone app. None have been charged from when this all worked. I've used both apps for years. This has never happened before.

I am using an iPhone 7, running iOS 12.3.

 

Hey folks,

 

Thanks for reporting this issue to us.

 

We’ve passed your info on to the relevant team, who are currently looking into it.

 

If you’re experiencing this issue, make sure to click +VOTE and Subscribe to the thread to be notified of any developments.

 

Could you also make sure to provide us with the following info, if you haven’t already:

  • device + OS version
  • exact Spotify version
  • steps to reproduce this issue?

Thanks! We’ll keep you posted and let you know as soon as we have any updates on this.

Comments
Alex
Moderator
Moderator

Hey there @Merkleyb,

 

Welcome to the Community!

 

We recommend you try disabling and re-enabling the automatic updates on your Sonos system, as well as performing a clean reinstall of the app, to make sure you're running the latest version.

 

You can always over to the official Sonos release notes page here for more info on the latest updates.

 

Hope this helps. If you have more questions, don't hesitate to reach out again.

 

Have a great day!

proone79
Visitor

Removing and reinstalling Spotify worked for me. Yay!

Ivan
Moderator
Moderator

Hey @proone79

 

Thanks for keeping us in the loop. 

 

We’re happy to hear this is fixed for you after reinstalling the app.

 

If you have any questions we're always one post away. 

 

Еnjoy your music!

maximillion82
Visitor
No it's not I still have it, on Mac, PC, Android and iOS clients.
JezzaCrab
Newbie

Still happening for me. Tried reinstalling, deleting cache, changing router network settings etc. Volume control works fine within the Sonos app (negating any possibility of network issues) but does not work properly in Spotify app on IOS. It’s driving me crazy and making me consider moving on from Spotify. What is the permanent fix Spotify? To me it sounds like a development issue.

Mihail
Moderator
Moderator

Hey @maximillion82 and @JezzaCrab,

 

Thanks for reaching out to the Community.

 

We're sorry to hear you're still experiencing difficulties with the volume control. If the steps that @Alex and @Ivan posted above didn't do the trick, we recommend that you unlink your Spotify account from Sonos. After that perform a clean reinstall of both the Spotify and Sonos apps and link them anew. You can bring up the clean reinstall guide for Spotify here. This support article can help with removing/ connecting Spotify and Sonos. This tends to resolve issues like the ones you're experiencing.

 

Hope you find this useful. Let us know how you get on.

JezzaCrab
Newbie

Hi, I tried all these steps and it didn’t seem to make any noticeable difference. One thing I have discovered though is that the controls all work perfectly on the IOS and IPadOS lock screens. On the lock screens everything is fast as expected. When using the Spotify app directly the controls are extremely sluggish again. Why would the Lock Screen work fine but not the app directly?

CarlosE
Moderator
Moderator

Hey @JezzaCrab,

 

Thanks for getting back in touch and for sharing that info.

 

Could you check if there are any battery optimization settings enabled for Spotify on your phone and disable them?

 

If that's not the case, could you try using a different account, like a friend's or relative's, and let us know if the issue persists? This would help us determine if this is account-related.

 

Keep us posted. We'll be on the lookout.

JezzaCrab
Newbie

Hi, using another account appears to make no difference. Also I’m not really sure what power saving feature I could turn off. Any other suggestions as to what could help?

CarlosE
Moderator
Moderator

Hi again @JezzaCrab,

 

Thanks for getting back in touch.

 

We're aware of this issue and the right teams are currently investigating and working on a fix. In the meantime, we recommend to keep the app updated.

 

Apologies for any inconvenience. If you need a hand with anything else, give us a shout.

 

Take care!