Announcements

[Web Player] [Firefox] Web Player won't start the next track

Status: Fixed

My web player does this weird thing and it's annoying. I start listening to e.g. an album, listen to a song and wait for the next one to start but it doesn't. I go to see what's up and the web player has gone to the next song but the song progress bar is almost at the end of the next song and paused. The song itself is not paused but the bar is static and no sound comes out. Any thoughts?

Hey folks,

 

The team have been looking at things here, and we can confirm this should now be fixed.

If you're still experiencing this issue, please can you make sure you've updated to the latest version of Firefox?

If this doesn't help, we'd recommend reaching out in a new thread so that we can better help.

Many thanks!

/M

Comments
tibi2626

Same here. 59.0.2 (64-bit) Firefox on Linux Mint 18.
There`s also a couple more threads about this.

_calm_bomb_

I thought I was alone....

 

I'm using Firefox 59.0.2 (64-bit) on Fedora 27

d01q97h8gzccyza

Probably the issue is only with Firefox. I have opened a ticket with support and mentioned this topic. So let's see the resolution. So far was recommanded to use different browser. I will contact them back tomorrow.

Roman2234

I can confirm that I don't have problems when using Chrome anymore. However, when using Firefox, playback usually stops after a few seconds or when trying to start the next song.

Sebasty

Hey @_calm_bomb_ and others

 

I'm also using Firefox (one of the beta versions) on Windows 7.

 

I initially had the same issue. Then I wiped cookies and site data for Spotify-related web sites, and then I accidentally clicked on "Go to song radio" instead of "add to queue" on some track.
Now I'm playing an album, no issues anymore with both queued tracks and album playback.

You can try clearing Spotify data by doing this:

1. Go to about:preferences

2. Click the "Privacy & Security" tab

3. Scroll to the 'Cookies and Site Data' part
4. Click on Manage Data
5. Write 'Spotify' to the search. Then click on 'Remove all shown'.
6. Click on 'Save Changes'. Firefox will ask confirmation on deleting the data of the chosen sites. Select 'Remove'.

If that didn't work, you can try choosing 'Song radio' instead of 'queue' like I did. :')

Keep me posted on how it goes 🙂

Vollkorn
Solved the issue for me. Although, my settings page looks a bit different.

-clear Spotify cookies
-clear cached web content
Sebasty

Hey @Vollkorn

 

That's very nice to hear!

 

However, could you try restarting your Firefox browser and report back if the issue returns or not? It returned for me.... 🙂

 

(Yeah, I realized the Betas may have additional features not available on stable Firefox versions. Sorry about that!)

edit: it works again after refreshing the web player tab. :')

_calm_bomb_

It worked for me too, but only after playing a song radio. Thanks!

_calm_bomb_

In fact, I retract my latest reply. I was listening to an album and it happened again. I deleted the cookies again and restarted the browser.

Then started playing an album and it happened again. The song plays until the end and then stops, but the progress bar is at 60-70% of the song.

tibi2626

Sadly this didnt work.
Here`s what my console is trying to tell me :

Content Security Policy: The page’s settings blocked the loading of a resource at self (“script-src”). Source: var _comscore = _comscore
XML Parsing Error: not well-formed Location: Line Number 1, Column 1: product_state:1:1
Will-change memory consumption is too high. Budget limit is the document surface area multiplied by 3 (845680 px). Occurrences of will-change over the budget will be ignored.

Env: prod