Web player stops after playing a song for 9 seconds

Spotify web player had worked fine for me for a long while (years), but a couple days ago started pausing playback at 9-second position very consistently. Switching to the next song (pressing the "Next" button) sometimes solves the issue for the next song playback (though, not always), then it happens again. Basically, it completely breaks the user experience, as I can't listen to songs which get stuck at 9 seconds, and have to manually press "Next" every 5-10 minutes.

 

I cannot see any errors in Chrome's JavaScript console nor any issues with the network requests. Everything is fine with my local network. The issue is only with Spotify's web player, and as far as I can tell, it is something that started happening just recently.

 

Any advice / help would be much appreciated.

 

Plan: Free

Country: USA

Device: MacBook Pro 2017

Operating System: macOS Big Sur 11.0.1

Web browser: Chrome 89.0.4389.90

Hello everyone,

 

due to recent developments, we're again marking this as Fixed.

 

We've made several backend improvements and from the previous comments those seem to have done the trick for a majority.

 

For anyone still experiencing this, it looks like the cause is a DNS issue via Chrome - something that's not under our control. All network communication for Spotify goes through the same domain name, so if metadata and playback commands are being sent, the domain is already resolved.

 

As such, if you're still having issues, please ensure to take the following steps to resolve this:

  • Change your default DNS in your network settings - It seems CloudFlare (1.1.1.1) is not an ideal pick, so if you have that one, change it to another DNS provider. Based on reports, Google's (8.8.8.8) is working fine.
  • Disable VPN, proxies or ad-blockers - they're not supported and are known to cause playback trouble.
  • Switch to a different browser for the Web Player - We've received reports that Firefox and Edge do not experience interruptions. As Edge and Safari are pre-installed on Windows and Mac those are good alternatives to use. If you don't want to make it your default browser, you can just create a custom shortcut for the Spotify Web Player to open in that browser. A good guide on how to do so can be found here.

 

Shoutout to @danth45 for helping find a solution!

 

Take care!

Comments
Alex
Moderator
Moderator

Hey there @csbubbles,

 

Thanks for reaching out about this in the Community!

 

Can you try the following and see if it helps:

  • Log out Everywhere
  • Try connecting to a different network, or create a mobile hotspot from your phone and connect via that network.
  • Try logging in with a different account

We've had other users report similar behavior from the web player and in most cases it is related to the users' network configuration or issues with the account itself.

 

Keep us posted on how you get on with this.

 

Cheers.

 

MrCorderoy
Visitor

Hi,
I am having the same issue. I have tried it on a couple of different computers, I have tried it on Edge and Chrome and the same thing occurs. I have tried restarting the computer, Clearing the Cache and signing out everywhere and it all works for a short time but then it starts again. Oh and it's also happening on different internet accounts, happens on home network, work network and hotspotting to phone.
It also isn't happening on the app (that is on my home computer but as I mostly use a work computer I can't download the app)

Eni
Moderator
Moderator

Hey there @MrCorderoy

 

Thanks for getting in touch about this. 

 

Would you mind trying again from an incognito window to check if the issue persists there?

 

If that doesn't change anything, we suggest that you try clearing any entries containing Spotify from the host files on your PC by following the steps in this guide.

 

Let us know how it goes 🙂

csbubbles
Regular

Nope, nothing works. I am also not sure if "in most cases it is related to the users' network configuration or issues with the account itself" is actually true. If one searches for "9 seconds" on this forum, they will find lots of reports about this exact issue, and the suggested solutions don't work for the majority of people there. Also, even if any of those actually worked, it's unclear why users would need to follow any of those steps every time it happens, as it's clearly some bug on the Spotify side. Considering that this has been happening to many people over a few years already (it appears to have been reported first back in 2017), is it possible to deliver this issue to Spotify engineers, so they could fix it, and no one would face this issue going forward? I would be more than happy to help investigate and provide any additional data if needed, so please let me know.

csbubbles
Regular

I can confirm that Spotify keeps getting stuck at 9 seconds in the incognito mode as well, and there is nothing in the system host files related to Spotify.

csbubbles
Regular

I am also pretty sure that network configurations have nothing to do with it. As I mentioned in my original post, there are no errors in Chrome's JavaScript and Network tabs in the Dev Tools (all the requests that Spotify made succeed with HTTP codes 200, 202, 206), see the screenshots attached.

 

Also, this issue happens only with Spotify. None of other online media services (YouTube, Pandora, Soundcloud, Bandcamp, Netflix, Disney+, etc.) experience anything like that. Not to mentioned that there is clearly something specific ("magical") about this number of seconds (9) Spotify gets stuck at.

 

Whether it's some issue in Spotify's web app logic, or not being able to process audio buffers in some cases, or not handling cached data properly, or something else, this is not that a user / listener does, but how Spotify's web app works. I have a feeling that if Spotify decided to investigate and fix it finally, many users would love to help and collect any data that might help Spotify's software engineers.

Screen Shot 2021-04-03 at 3.18.39 PM.png
Screen Shot 2021-04-03 at 3.19.00 PM.png
csbubbles
Regular

One warning in JavaScript Console that I can see is in the attached screenshot. I doubt it's relevant, but just in case anyway.

Screen Shot 2021-04-03 at 3.30.48 PM.png
CarlosE
Moderator
Moderator

Hi again @csbubbles,

 

Thanks for keeping in touch and for the extra info.

 

We're afraid this has to be looked into case by case, as it isn't an issue that affects all users. We've tried it with different accounts and networks and couldn't replicate it.

 

Can you let us know if the same happens when using a different browser? We'd also like to know if it happens in the desktop app.

 

Additionally, could you try logging in to a different account, like a friend's or relative's, and let us know if the behavior is the same? This would help us narrow down the possible cause of the issue, which can be different for each user.

 

We'll keep an eye out for your reply.

1127473940
Newbie

Plan

Premium

Country

Germany

Device

Desktop PC (no chromebook)

Operating System

Windows 10

 

My Question or Issue

Since yesterday it happens that roughly on average every 2nd to 10th song stops 9 seconds into the track. To "solve" it I need to skip to the very beginning of the song and then skip behind the 9 seconds mark by hand - which is obviously very annoying. It does not depend on the track, it can be anyone in any playlist whatsoever.

I'm using the web player in chrome in latest version 89.0.4389.114 (official build) (64-Bit) and did not change my setup (as it worked previouly fine - like any other streaming service I use is working properly) and therefore I doubt the problem is my side.
I did check for similar threads about this topic like https://community.spotify.com/t5/Desktop-Windows/Chromebook-Song-stops-randomly/m-p/4780289, but it seems outdated and does not a provide a proper solution.

9s-stop-2.jpg
9s-stop.jpg
gurman_ua
Visitor

I have the same issue on Web Player in Chrome (also in Chromium) on Linux Mint 20. I have no problem with my network on hard tasks (like 4k videostreaming on several devices semultaniously). I have no problems with my sound hardware or software. I have actual versions of browsers and other software. Also I cleaned browser cache, relogined, rebooted OS, etc. But still I have that issue.
It was sometimes last month. But last few days it happens almost on every second song.

When it happens buttons "Unpause", "Backward" dont work. It is only one way to unblock music - "Fast forward" and then "Backward".
I cannot use your service and I cannot listen music in such way.
I'm not sure but it seems like Chrome blocks incorrect operation in Web player's js-code.

gurman_ua_0-1617583619031.png

 

Related Issues