When I start the web player one of my monitors shuts off/loses connection







Operating System

Windows 10


My Question or Issue

 How can I prevent my monitor from shutting off when I start the web player?

Hey there folks,

We really appreciate your patience and all your reports so far.

We've passed them on to the right teams and after checking this, we've come to the conclusion that unfortunately this isn't something we can help with further on our end.

If there's anything else you need help with, don't hesitate to let us know by starting a new thread in our Help Boards. Thanks!


 Becuase at work I have VPN which prevents me to log in on my account in the app (this I also consider really  annoying) I use  web player. And this issue is happening both on chrome and firefox. Only on Edge monitors doesn't  turn off. But web player does not work correctly on edge.  It stops playing after a while or it skips songs on the playlists. Because I mostly use Spotify at work I'm considering resigning from premium account over this. It  happens to a lot of users, so it is definitely the fault of the web player and something  should be done about it. Telling that you can't help without giving any reasoning behind that is not a solution


I was having the same issue! We use Dell thunderbolt docks at work and it was completing resetting my monitors when the web player page loaded and again when I clicked play.


Resetting the dock has stopped the issue for now.

Unplug laptop from dock, unplug power cable from dock, hold power button for 10ish? seconds, plug power cable back into dock, plug laptop back into dock.


Good luck

Try WINDOWS+CNTRL+SHIFT(hold down all) press B.  This resets your graphics driver.  Works great for me.  Thanks for the reply tough if this method ever stops I can try it your way
Good luck

Seems quite strange to see that Spotify really just ignores the issue without at least trying to explain what steps they did to mitigate the issue and what were their findings that made them to decide they won't fix the issue.


@ShogunYama- thanks for the workaround (!


Been a paying premium member for over 10 years. Just cancelled my membership over this unresolved issue. What a shame. I can only vote with my pocket book. 


Same happening here. 

ChromeOS on Chromebook pixel + external LG monitor(using USB-C to HDMI adapter).

Webplayer is running as a web application(clicked on "+ install" button after load it for the first time.


When I click on the "play" button at any song, it turns the monitor off and then on. That's really weird and TBH, it's such a relief to know it's not only me on this boat.


Regards, Vinicius


When I change the monitor refresh rate to 75Hz or 60Hz (2560x1440 resolution) in the graphics adapter settings, I have the same problem (ASUS-ZenBook-14 Notebook + 32 "AOC monitor via HDMI) I always had to turn the monitor off and on or reset the graphics adapter (shortcut Win + Ctrl + Shift + B) But when I set the default value to 59Hz, everything works correctly and the monitor no longer turns off! So maybe this information will help someone.;)


Having the same issue; Lenovo P1 G2 laptop, Lenovo Thunderbolt Docking Station. Monitors are DisplayPort plugged into the docking station. Whole docking station goes dead. LAN, Sound, Video, USB.


Same happens to me. My workplace blocks the Spotify App, so I use the web player and every. single. time. both my monitors go static. The Win-Ctrl-Shift-B trick workaround works, though. It would be great if Spotify cared enough to try fixing this. I am a paid member.


It's been two years and this seriously still has no fix?

Related Issues