When I start the web player one of my monitors shuts off/loses connection







Operating System

Windows 10


My Question or Issue

 How can I prevent my monitor from shutting off when I start the web player?

Hey there folks,

We really appreciate your patience and all your reports so far.

We've passed them on to the right teams and after checking this, we've come to the conclusion that unfortunately this isn't something we can help with further on our end.

If there's anything else you need help with, don't hesitate to let us know by starting a new thread in our Help Boards. Thanks!


That solution from @ShogunYama fixed my issues.  I'm able to run Spotify and all the other streaming services I was having an issue with. Thanks @ShogunYama 

Possible band-aid to this mess of a web player. Force your computer to sleep. Waking and signing back in has been resolving the flicker. -Running Win10

I think its ridiculous that this is not being investigated and your response is sorry we can't help further.  Chrome is the issue here.  Please look into this further!


Same here. Windows 7, laptop with two external monitors. Web player sends both monitors into sleep mode.


Sorry to say but you not solving this because you don't feel like it has got to be a joke. There is no good reason why an essential component of a music player would in any way interfere with display hardware.  I am a paying customer. I you don't provide an app that works, I will take my money elsewhere.

I found a solution by shutting off the hardware accelerator in chrome and
that solved the issue.
Casual Listener

@joyciebabe On my work machine, disabling hardware acceleration in chrome when using the Spotify player causes the mouse to stutter, lock-up and become otherwise unresponsive every second or two  while playing music. So the machine is still not really usable like that.


Other media players online do not exhibit this problem. Using Microsoft Edge also does not exhibit this problem but I receive warning that it is not compatible without updating even though I am on Edge 40 (and cannot update as it is company controlled).


So my options are still either: IE (doesn't work at all), Chrome (flickering screen or unresponsive mouse if hardware is disabled), Edge (not officially supported and many visual problems when using, such as having to scroll way down an empty screen to see the playlists and music).


After seeing the response from Spotify, I pretty much gave up on ever being able to use a service I pay for during the 40+ hours a week that I'm at work.  (Realllllllly disappointed in you, Spotify..... SMH)


However, I too just tried the suggested fix from @ShogunYama and lo and behold, screen flicker/on/off is resolved.



This is still happening. No other website has ever done this to my monitors, but Spotify can't do anything about it? Very interesting that they've chosen to ignore it and don't explain why.


Has anyone figured out what causes this issue? I am currently having it occur on our PC.


edit: oh I see spotify has decided to drop the ball here... guess we wont get a solution. Guess I just use apple music for our weekly services.


Bumping @ShogunYama and his answer about the Generic PnP Monitor, this fixed my problem at home and at the office (same laptop, different monitors).


It started for me several months ago and I never had a real solution (I was opening Spotify in FireFox while doing everything else in Chrome, but that only worked "sometimes"). After disabling the monitor, no more issues.