Announcements

Help Wizard

Step 1

NEXT STEP

Wrong metadata displayed on car radio via Bluetooth

Hi!

On my Mazda 3 2018 the song title and song name freezes after first track is played after i start my car. The forward and backward buttons to change song  on my steering wheel still works though.

 

This is with my Oneplus 7t Pro connected through bluetooth. This started to happens after two (or one, cant be sure) updates of Spotify ago.

 

Hello all,

 

We can confirm that the underlying root cause for what caused this issue when it was first opened has been resolved. The amount of votes per week and reports this issue has received have slowed down considerably and we see quite a few confirmations that everything works as usual, which confirms that for the majority of users, this should be fixed and the remaining reports have different causes.

 

We've noticed Pioneer and JVC-Kenwood radios being mentioned in the posts. If that's the case, check here for more information, as these are unrelated to this investigation.

 

There is a subset of other devices which still experience a variant of this issue - delays in the metadata updates or similar. Investigations have shown that these are most likely caused by deep sleep regimes or the odd BlueTooth incompatibility.

 

Full support is only possible on Apple CarPlay and Android Auto enabled dashboards. We'll keep tweaking and optimizing the app to try and alleviate issues, however we cannot guarantee complete functionality across all different car and phone models. Some users have posted different alternatives in this thread that could help so it's worth trying those out.

 

If there're any further updates, we'll make sure to post them.

 

Take care and safe driving!

Comments
Novy

Hey @Escaleok

 

Thanks for reaching out about this and letting us know what you've tried.

 

Would you mind sending over a video where we can take a better look at this issue?

 

You can attach it to your next response to us by using the Insert Video option in the post editor or you can also send us a link to it. Just make sure to exclude any personal info from it. 

 

We'll keep an eye out for your reply.

rwynne
I am having the same issue. Mazda3 2017, One Plus 7T Pro via bluetooth. This all of a sudden started happening last week. Definitely a software issue, as older versions of Spotify are not doing this.
CarlosE

Hey there @rwynne,

 

Thanks for posting on this thread.

 

Could you let us know if using a different type of connection, like a cable, makes any difference?

 

It'd also be helpful if you could try using a different mobile device that isn't a OnePlus and let us know how it works. This will help us narrow down the possible cause of this issue.

 

Keep us posted. We'll be on the lookout.

Peo76

Hello 

I have made a video. 

It's a bit short but you can see no metadata on the screen. Sometimes says "unknown", sometimes blank. 

With the cable runs everything fine. All metadata is on the screen.

https://drive.google.com/file/d/1HzQ6MqCZvg3pcAdzJ4Gjw3Pt_b-KPnXf/view?usp=drivesdk 

CarlosE

Hey @Peo76,

 

Thanks for getting back in touch and for that info.

 

This issue seems to be only affecting OnePlus devices. In order to further look into this, could you let us know the OS version of your OnePlus 6, along with the Spotify version you're running?

 

We'll keep an eye out for your reply.

rwynne
It is a OnePlus 7, not 6.
OS version is Android 10.
CarlosE

Hey @rwynne,

 

Thanks for that info.

 

Did you already try using a different type of connection and a different mobile device? This would be helpful to further investigate.

 

Also, remember to let us know the exact Spotify version you're running.

 

Keep us in the loop.

Peo76
OnePlus 6 with OxygenOS 10.3.8 (Android 10)
Spotify 8.6.2.774
The issiue came about two versions ago.
rwynne
Spotify version 8.6.4.772.
Thanks.
Escaleok

OnePlus 6 with Android 10

Spotify 8.6.2.774

The issue only occurs with bluetooth. If i plug the mobile through cable, works fine.