Announcements

Help Wizard

Step 1

NEXT STEP

Wrong metadata displayed on car radio via Bluetooth

Hi!

On my Mazda 3 2018 the song title and song name freezes after first track is played after i start my car. The forward and backward buttons to change song  on my steering wheel still works though.

 

This is with my Oneplus 7t Pro connected through bluetooth. This started to happens after two (or one, cant be sure) updates of Spotify ago.

 

Hello all,

 

We can confirm that the underlying root cause for what caused this issue when it was first opened has been resolved. The amount of votes per week and reports this issue has received have slowed down considerably and we see quite a few confirmations that everything works as usual, which confirms that for the majority of users, this should be fixed and the remaining reports have different causes.

 

We've noticed Pioneer and JVC-Kenwood radios being mentioned in the posts. If that's the case, check here for more information, as these are unrelated to this investigation.

 

There is a subset of other devices which still experience a variant of this issue - delays in the metadata updates or similar. Investigations have shown that these are most likely caused by deep sleep regimes or the odd BlueTooth incompatibility.

 

Full support is only possible on Apple CarPlay and Android Auto enabled dashboards. We'll keep tweaking and optimizing the app to try and alleviate issues, however we cannot guarantee complete functionality across all different car and phone models. Some users have posted different alternatives in this thread that could help so it's worth trying those out.

 

If there're any further updates, we'll make sure to post them.

 

Take care and safe driving!

Comments
rwynne
No, I'm sorry this is the only phone I have. Have had it for over a year.
I connect to my Mazda3 2017 via bluetooth. Changing tracks from the
steering wheel works fine. But the song title doesn't change on the car
display.
Sometimes I will have Waze running at the same time, but not always.
And also I noticed just this morning this was also happening as a bluetooth
connection to a new Subaru.

I'm sorry I can't offer any more details. This seems to be a OnePlus issue
y'all need to look into. Looking forward to a fix. Thanks.

CarlosE

Hey folks,

 

Thanks for bearing with us and for the info shared.

 

Can you let us know if this issue only happens when connected via Bluetooth? Could you try using a cable and Android Auto, if possible, and let us know if the behavior is the same?

 

Also, you may need to select your car as a default device or allow media sharing. Try looking for those options in the Bluetooth settings of the device you’re playing from. If the problem persists, check out the support site for your devices’ manufacturers.

 

We'll be on the lookout.

Peo76
Hello CarlosE
Have you read all the posts?
The problem happens on OnePlus smartphones over bluetooth connection.
Cable connection runs finely. Tidal runs finely. Amazon Music runs finely. Youtube runs finely.
Have you got any solution? Or are you posting a pre-written answer?
WE WANT A REAL SOLUTION! NOT QUESTIONS!
PLEASE READ ALL THE POSTS!!!
I tried also the latest version available 8.6.4.971 the problem still persists.
Honestly, I'm thinking to go definitively to Tidal.
This is not the support I'm expecting from Spotify.
CarlosE

Hi @Peo76,

 

Thanks for your reply.

 

We're asking those questions to all the affected users in this thread so we can identify the possible root cause of the issue and work on the fix you need. The more info we gather, the easier we can narrow down this and further investigate to come up with the solution.

 

We appreciate your patience and all the info you've shared with us.

 

Cheers.

rwynne
Hi, the Mazda3 2017 doesn't come standard with Android auto. The cable is
only for charging, so bluetooth is all I use.

Thanks.
CarlosE

Hey folks,

 

Thanks for the info shared.

 

The issue seems to be isolated to OnePlus devices and how the data is being transmitted via Bluetooth, as it doesn't happen with different devices and different connections. Could you check in your phones if there are any Bluetooth-related settings that might be causing this behavior? We recommend reaching out to the devices' manufacturer for more info about this.

 

Keep us posted.

Escaleok

If the issue were with the phone's bluetooth connection, it would also fail in other apps and not only in spotify, don't u think?

Peo76

Hello

I have done a factory reset, so the bluetooth settings are untouched. 

I also checked the bluetooth settings and they are correct. 

I need to remember to you that Tidal, Amazon Music and YouTube runs finely over bluetooth and they have non issues. So the issue is born on Spotify; not a OnePlus fault! 

Mihail

Hey folks,

 

Thanks for reporting this and for the troubleshooting so far.

 

We've gathered all info and passed it on to the relevant team. They'll happily take a closer look. We'll keep you updated on any news on the matter here, as soon as there are any.

 

Hope this shines a bit of light on the matter. We'll be here if you have any other questions.

Peo76

Hello

 

Tried 8.6.8.1094 version a couple of minutes ago.

The issue is still present. 

I hope for a quick fix 😉