cant connect to device (spotify connect)

Device: Onkyo TX-NR636

 

Since 1-2 weeks i cannot connect to the above device anymore. I used my smartphone (Iphone6 with latest app) and my desktop client (ubuntu 16.04).


It list the device as available but it wont connect.

The desktop client shows this in the logs:

 

16:01:54.006 D [gaia_manager.cpp:1170           ] GAIA: TIMING(37996885) GaiaManager::sendHelloHelper
16:01:57.008 D [gaia_manager.cpp:1186           ] GAIA: GaiaManager::hermesDeviceCheck
16:03:15.436 D [gaia_manager.cpp:655            ] GAIA: TIMING(38078316) GaiaManager::playCurrentStateRemote (connect:AVR:::LOGGED_IN) mdns:SpotifyConnect._spotify-connect._tcp.local
16:03:15.436 D [gaia_connect_impl_v1.cpp:332    ] GAIA: TIMING(38078316) GaiaConnectImpl_V1::forceLogin
16:03:15.436 D [gaia_connect_impl_v1.cpp:303    ] GAIA: TIMING(38078316) GaiaConnectImpl_V1::loginUser
16:03:20.527 D [gaia_connect_impl_v1.cpp:128    ] GAIA: TIMING(38083407) GaiaConnectImpl_V1::onResult (empty JSON), retrying
16:03:20.527 D [gaia_connect_impl_v1.cpp:303    ] GAIA: TIMING(38083407) GaiaConnectImpl_V1::loginUser
16:03:25.571 D [gaia_connect_impl_v1.cpp:81     ] GAIA: GaiaConnectImpl_V1::requestFailed: cmd=1, device=mdns:SpotifyConnect._spotify-connect._tcp.local, error=3
16:03:25.571 D [gaia_manager.cpp:2004           ] GAIA: GaiaManager::deviceLoginFailed: mdns:SpotifyConnect._spotify-connect._tcp.local (pending 1)
16:03:28.021 D [gaia_manager.cpp:941            ] GAIA:   current state ID updated to -453007536
16:03:28.023 D [gaia_manager.cpp:941            ] GAIA:   current state ID updated to -453007534
16:03:28.024 D [gaia_manager.cpp:941            ] GAIA:   current state ID updated to -453007533
16:03:28.026 D [gaia_manager.cpp:941            ] GAIA:   current state ID updated to -453007532

No worries!

 

Don't hesitate to contact us if anything else comes up.

 

We'll be happy to help 🙂

Status: Fixed
0 Likes
Comments
MaryC1
Spotify Legend
Status changed to: Fixed

Hi @skulli, thanks for coming to the community for help.

 

Is this issue affecting both devices your iPhone and desktop client? Also, can you try restarting the router or using a different network and see if it makes any difference? 

 

We don't officially support Linux, but we'd suggest you to follow the steps on this thread.

 

Keep us posted.

Alejandro_C
Spotify Legend
Status changed to: Fixed

Hey @skulli!

 

We haven't heard from you in a while. Did the previous steps help at all?

 

We look forward to your response. 

skulli
Casual Listener

The problem i had on all clients. By now it solved "itself". I think i had local DNS problems with my provider. On my clients i used a custom dns entry to avoid the connectivity problems but the device had the default dns and had no chance to connect.

 

Thanks anyway 🙂

Alejandro_C
Spotify Legend
Status changed to: Fixed

No worries!

 

Don't hesitate to contact us if anything else comes up.

 

We'll be happy to help 🙂

radlat
Newbie

The same issue:

10:51:35.076 D [gaia_connect_impl_v1.cpp:715    ] GAIA: TIMING(118737684) GaiaConnectImpl_V1::forceLogin
10:51:35.076 D [gaia_connect_impl_v1.cpp:680    ] GAIA: TIMING(118737684) GaiaConnectImpl_V1::loginUser
10:51:35.076 D [gaia_connect_impl_v1.cpp:664    ] GAIA: GaiaConnectImpl_V1::getConnectCredentialsAsync: create a token with type "default"
10:51:40.089 D [gaia_connect_impl_v1.cpp:200    ] GAIA: TIMING(118742698) GaiaConnectImpl_V1::onResult (empty JSON), retrying
10:51:40.089 D [gaia_connect_impl_v1.cpp:680    ] GAIA: TIMING(118742698) GaiaConnectImpl_V1::loginUser
10:51:40.089 D [gaia_connect_impl_v1.cpp:664    ] GAIA: GaiaConnectImpl_V1::getConnectCredentialsAsync: create a token with type "default"
10:51:45.101 D [gaia_connect_impl_v1.cpp:153    ] GAIA: GaiaConnectImpl_V1::requestFailed: cmd=1, device=mdns:...._spotify-connect._tcp.local, error=3
10:51:45.101 D [gaia_manager.cpp:2303           ] GAIA: GaiaManager::deviceLoginFailed: mdns:...._spotify-connect._tcp.local (pending 1)
10:52:00.217 D [gaia_connect_impl_v1.cpp:153    ] GAIA: GaiaConnectImpl_V1::requestFailed: cmd=0, device=mdns:...._spotify-connect._tcp.local, error=3

Aleyna222
Newbie

HI I make a playlist on my Spotify account and when I press play on the playlist it plays different songs not the ones on the playlist I'm hoping someone can help me? 

Related Issues