[iOS] Cover art + track title is "stuck" on the first track played on BMW head unit

Track titles and cover art is not displayed correctly on BMW (2015) when playing through Bluetooth or the USB interface in the center console.

 

Symptom: Music plays and it is possible to switch tracks, but the cover art and track title is "stuck" on the first track played. It played great in the past and playing well with other music apps.

 

Device

(iPhone Xs) Running version 13.3.1

Car: BMW X6M 2015

Hey folks,  

 

We haven't had any updates for you all in a while and in the interest of keeping this thread updated for other users stumbling upon it, we'll go ahead and mark it as Won't Fix for now. 

 

Rest assured that we've passed on your reports to the teams around this. This is a very specific issue to this particular device setup with BMW head units and seems to be affecting only a smaller subset of users. However, if you're experiencing something similar but on a different head unit, we'd recommend starting a separate thread here so we can take a look. 

 

Keep in mind that this doesn't eliminate that a future update of the app could improve things for you, so keeping the app always updated is a great idea.

 

We do appreciate you taking the time to add your comments in this thread! If we have any further updates for you regarding this, we'll make sure to share them in this thread with you.

Comments
Xenia
Moderator
Moderator
Status changed to: Not Right Now

Hey there folks,

 

Thanks for bringing this to our attention. We've passed on all your feedback to the right teams who are continuing looking into this.

 

However, we're not able to provide an exact timeline for a fix, so we'll mark this Ongoing Issue as Not Right Now.

 

In the meanwhile, we'd recommend always keeping your Spotify app up to date to ensure you're rocking the latest improvements and fixes.

 

We'll keep you updated here once we have any further updates to pass on. 

Phil93
Newbie

Hello Again,

since my latest post (Feb) I got a new I-Phone SE 2020.
SW Version: 13.6
Vehicle: BMW F31 2014 HU NBT: newest Software


Additional I tried several other I-Phones from colleagues, same Issue. (Iphone 6 up to 12pro)

From my point of view it is unbelievable that Spotify isn’t able to fix such a minor Bug within 8 Month!
Is it that hard to compare the SW Releases of January and February to find the Issue in your BT Stack?

Over all I am really disappointed about the poor customer Service and how they deal with paying customers.
No personal contact to the Problem finders, bad excuses and no progress

counting6
Regular
I absolutely agree with you. This is very poor customer service.



asangel
Newbie

Hello, Spotify Team,

 

It’s been over since 6 months since listeners informed you about the title track issue in a car.  I personally contacted you multiple times.  It’s not fun if you’re driving for hours somewhere and all you see is the same title that appeared when you got it your car.  It’s obvious that you guys don’t care because you still get paid and we don’t cancel our memberships.  And, funny enough, it’s been MONTHS since you thanked us for drawing your attention to this issue.  Is there any way you would stand behind your product and service?? Is there any way you would resolve this issue for your clients?? Let us know so we can make a decision to switch to iTunes.  BMW 328i 2014.  The issue has been present since 2019. 

counting6
Regular
I am also going to be making a move on my choice of music app. This is by
far the worst customer service I have ever had.
asangel
Newbie
Hey! I can’t believe we’ve been dealing with this for a year and they didn’t lift a finger to fix the issue. Ugh
emko1994
Visitor

Hi,

 

I have te same problem since january. I have tried everything, but nothing works.

 

BMW 7series F01 2014
iPhone XS iOS 13.6.1

Spotify 8.5.72.905

 

Please fix this!

Amel_
Visitor

Exactly the same problem here.

First occured in February

2015 BMW

iPhone XS

Horrible customer service..

 

counting6
Regular
I absolutely agree that the customer service is horrible. There is no
reason for this issue to be ongoing for so many months. I would never
recommend Spotify to anyone.
0ultq-b6j_1pr
Newbie

Was so happy when I found this post, to find that I was not the only one having this issue as I’ve only just gone back to iPhone. 

Bit devastated to find this issue has been going on for 10 MONTHS?!