[iOS] Error message "Something went wrong" when logging in while connected to mobile data

Status: Fixed

Hey everyone,

 

We're receiving reports from users that when they try logging in to their account while using their mobile data, they get an error message "Something went wrong. Try again". According to the reports we're getting, it seems like this is impacting Telstra customers.

 

If you’re experiencing this issue, make sure to add your +VOTE and follow the instructions in the Status Update below.

 

We'll be keeping everyone up to speed here, so make sure to subscribe to this thread!

Hey folks,

 

We’re happy to say that this should now be fixed for those who use the Telstra network!

 

 In case the issue continues with a different/same network, make sure to: 
 
  • Check if the device meets all requirements.
  • Check if the network/service provider is from a market where Spotify is supported.
  • Reach out directly to the service provider.
If everything seems to be fine, make sure to post a new thread in the relevant help board here.

 

Thanks!

Comments
vespertine3

Hello, so basically this issue has been starting since yesterday.

I have noticed if I use my cellular data on Spotify and I enter a playlist the songs become greyed out?

I tried logging out and had a strange error when logging back in with cellular data… it would say “Something is wrong, try again later.” But what made me log in was my current working Internet, it wasn’t my password or anything associated with my email. I soon realised that it had to do with my 4G. It must be a big because I am able to log on and listen with Wi-Fi everywhere… but when I am on my data… nope. I can only listen to albums and not the playlists I listen to.

Plan:

Premium

Country:

Australia, NSW

Device:

iPhone 12 Pro 256GB

Operating System:

iOS 15.1.1

My Question or Issue:

Please help! This has been happening lately and I need help as soon as possible!

Fredd_0_Six
Telstra know about this. I called them and they updated or changed a setting. I think APN issues. I rebooted my iPhone 13 Pro Max and Spotify is back to normal.
vespertine3

Still doesn’t work mate,

I have restarted my phone and it still shows this.

Fredd_0_Six
Did you speak to Telstra?
Irvinlaw

i spoke with telstra and they asked me to switch my mobile off and on - 10 seconds waited. Uninstall and reinstall the app. I cannot login the app using telstra network


This is definitely something related between telstra mobile network and Spotify. Once I connect to wifi on a non telstra network, I can log into Spotify without any problem - all songs can be streamed.

 

afterwards I switch off the wifi and reconnect to telstra network again - all the online songs are grey out and become not accessible.

Beanm

I’m in the UK and also having this issue! Currently on Wi-Fi and still can’t login 

philwmorgan

I have experienced exactly the same issues as described here.  (Locked up Spotify playlists, only able to shuffle, deleted the app and re-installed but wasn't able to log back in again) I'm glad it wasn't just me. 


As suggested, this appears to be a Telstra network issue.

I connected to a WiFi network and was immediately able to login to spotify, issues gone.
I haven't contacted Telstra support yet, however changing to a backup APN makes sense to rectify the issue.    Can someone please post which APN Telstra advise to use that resolves the problem?

Thanks Spotify Community!  🙂

Fredd_0_Six

Phil…Telstra didn’t say what they did but I’m guessing something to do with APN settings. If it’s still not working through mobile data then give them a call back and tell them it’s definitely a Telstra issue. 
Mine has been working fine since yesterday.

Dpcann1

Plan

Premium

Country
Aus

Device

iphone 12

Operating System

ios15

 

My Question or Issue

Hello
My spotify on my Iphone 12 (iOS15) is randomly showing grayed out songs which sometimes play and then sometimes don't play.
 
Playlists only work if I press shuffle even though I can't individually press on songs.
 
I have reinstalled the app twice and changed whether it's on wifi/cellular and I'm still having the same issues.
 
I have attached examples of the issue I have.
265237431_314602194002968_2126231333086632860_n.jpg
SamS13

Same issue for me on telstra in Australia