[iOS]Not able to control the volume on a device while using Spotify Connect

Plan

Premium

Country

The Netherlands

Device

iPhone 11, Speaker: Naim Muso 2

Operating System

iOS 14.4.1

My Question or Issue

I keep losing the ability to control the volume of a device I connected with through Spotify Connect, specifically my Naim Muso 2 speaker. After several minutes after connecting with the device and playing a song, my iPhone seems to switch to controlling only the volume of media played directly on the device itself. Force shutting the app doesn't help and i need to disconnect from the speaker and reconnect again before I can control the volume again. I already tried restarting my devices, even my router. I also tried to turn of the 5GHz band, so that all device would operate on the same frequency band. Nothing seems to help, does anyone have a solution? I know I can use Airplay or Bluetooth, but this seems tedious as Spotify Connect would be he best option if the volume controls wouldn't drop out.  

Hey folks,

 

Thanks for reporting this issue to us.

 

We’ve passed your info on to the relevant team, who are currently looking into it.

 

If you’re experiencing this issue, make sure to click +VOTE and Subscribe to the thread to be notified of any developments.

 

Could you also make sure to provide us with the following info, if you haven’t already:

  • Device + OS version
  • Exact Spotify version
  • Type, brand and model of the speakers or device that you're trying to Connect
  • Troubleshooting steps you've tried so far

Thanks! We’ll keep you posted and let you know as soon as we have any updates on this.

Comments
Alex
Moderator
Moderator

Hey @Canis_Lupus27,

 

Thanks for reaching out about this in the Community!

 

Can you let us know if you can control the volume through your phone if you open the Spotify app, go to the Now playing view and there you should be able to see the little green Connect icon. Once you've clicked that you should see a volume slider. Does changing the volume from there work on your speaker even if you've lost the ability to control the volume of the speaker with the volume buttons on your phone?

 

We'll be on the lookout for your reply.

Canis_Lupus27
Casual Listener
Hey @Alex,

Thanks for your reply. Unfortunately this doesn't work. I am able to play, pause and skip songs, but I can't seem to control the volume in any way. Neither the volume buttons, nor the sliders in the app seem to work after a few minutes. My internet connection seems stable, as I can keep controlling the music. Furthermore, controlling the volume through the native Naim app also seems to work properly. It only seems that volume control through Spotify Connect 'loses connection' after a few minutes.
Alex
Moderator
Moderator

Hey @Canis_Lupus27,


Thank for the reply.

 

I had a closer look in our Spotify Connect supported devices and it looks like second gen Niam speakers are not listed there. Which may explain why you're having issues with the connectivity over Connect.

 

Another thing worth checking is the WiFi itself. Can you try creating a mobile hotspot from your phone and connecting both the phone and the speaker to the new network. After that check if you get the same control issues. 

 

Keep us posted on how you get on with this.

 

 

corysmith01
Visitor
Hi, I came searching for the same issue and came across this. Exact same behavior is now being exhibited by my spotify app (on iphone Xr if applicable). For well over a year now, spotify app has worked flawlessly controlling my Audio Pro Addon C10, wich is an approved device. However, about a month or so ago, I too lost the ability to control volume. All other controls work, but using the phone volume up/down does not change anything. It DOES show within the app. The icon for the speaker comes up and it shows the volume increasing, however it has no actual affect. The volume remains the same from the speaker. I have to navigate over to my Audio Pro app to control the volume, which of course works fine. So something changed. As mentioned, this is new behavior. The phone has been restarted, as has the connection to the device and network. Would love to get that back as being able to control all aspects from spotify is far more streamlined.
Alex
Moderator
Moderator

Hey @corysmith01,


Thanks for reaching out about this.

 

Can you let us know if the volume control works normally from another device like a pc or the web player? This will help us figure out if the issue is related to the latest iOS release.

 

Also, check if you get the same behavior when connected to a mobile hotspot.

 

We'll be on the lookout for your reply.

corysmith01
Visitor
I just checked via laptop and works fine there, volume slider within the spotify interface controls volume. Interestingly, now having switched from laptop back to iphone, I now can't get the iphone to exhibit this behavior...volume control is working as expected. One difference however is that I need to actually be within the app. Previously, I could control the volume just by lifting the phone/waking, or being within another app. That's now gone. Meaning, I have to actually be within the spotify app for the volume to work. Previously I could control it from any app, say if I was using Safari and wanted the volume down, it would work. Apologies, can't do the mobile hot spot at the moment. Hope this helps.
Alex
Moderator
Moderator

Hey @corysmith01,


Thanks for the info and going through this troubleshooting process with us.

 

Can you let us know the exact version of your Spotify app? We need this info in order to report this issue to the right team at Spotify.

 

We'll be on the lookout for your reply.

corysmith01
Visitor
Sure thing: version 8.6.12.1032
corysmith01
Visitor
Spoke too soon...volume ceased working again. Trying to backtrack what I did. It was working fine until I just switched albums. Once I moved to a new album, it lost its ability to control volume. Hope that helps.
Alex
Moderator
Moderator

Hey folks,

 

Can you make sure your phone is running the latest version iOS version 14.2 and after that run a clean reinstall of the app, following the steps provided in this article exactly. 

We tried preproducing this on our end and after the update everything works as expected again.

 

@corysmith01, if this doesn't do the trick for you, can you try to restart your router and see if that makes a difference.

 

Keep us posted.