Help Wizard

Step 1


[iOS] Wrong podcast episode played from Search

We've received multiple reports that when a podcast episode is played from the Search bar, another episode gets played instead of the one selected. This is happening on iOS devices.

Hi everyone,


Thank you for your posts and the info you've provided. 


We've received word that this issue should now be fixed in the latest app release. If you haven't already, please update your app to Spotify for iOS version 8.8.36.

If you're still experiencing this issue, there is also the following workaround: Playing the episode directly from the search results, or by adding the episode to Your Library and playing from the library. If the issue persists, let's recommend utilizing the web player for the mean time.

situation: search for a podcast via the search banner, click the green play button that appears next to the episode in the search results, Spotify starts playing an episode from within that podcast but not the episode I searched for and clicked on. To listen to the episode I wanted to I had to navigate to the historical episode in the podcast home page. This repro’d for me multiple times on different shows, appears to happen with podcasts that have a lot of episodes that go back beyond ~2019






iphone 12

Operating System

(iOS 10, Android Oreo, Windows 10,etc.)


My Question or Issue



Hey there @Superandy89


Thanks for reaching out about this and welcome to the Community! 


Could you let us know if this happens across devices or only on a specific one?


If this happens only on a specific device, could you try logging out and then logging back in twice in a row? This will trigger a sync between your device and account. 


If this doesn't do the trick, it's well worth running a clean reinstall to get rid of any cached files that might be causing trouble.


If the issue persists afterwards, would you mind sending us a short screen recording of the issue happening so we can take a closer look? You can attach it to your next response by using the Insert Video option in the post editor. You can also upload it to Google Drive and share the link with us (make sure the video has the permissions for anyone to see it).

We'll be on the lookout for your reply. 


I am having the same issue. I tried logging out twice, and also did a clean reinstall; neither solved the problem. This just started yesterday after I updated the app on my iPhone. I attached a video example. 


Happens to me as well


I have the exact same issue here. So annoying! 


Hey there,


Thanks for bringing this to our attention.


In order for us to relay your reports to the tech team, we'd need the Spotify versions you've installed on your devices together with the brand, models and operating systems of the devices.


Also try using a different account to see if the issue persists.




I'm having this issue on every single podcast I've attempted to listen to today and it's been infuriating.


Listening on an iPhone 12 Pro Max (iOS 16.4.1(a)) on the Spotify app (v8.8.32.533).


Please fix this.  I was hoping to get through some episodes today and Spotify has been completely unusable for podcasts.  Want to listen to the first episode of Lore? NOPE, any episode you try will start episode 50 (seriously, ANY episode I try loads that specific episode).  All other podcasts are behaving the same way for me too.  For every podcast there is ONE specific episode that ALL episodes in that podcast will start.


I functionally CAN NOT listen to podcasts on Spotify right now.  I've tried logging out and back in 7 times and it still occurs. There are no present app updates and I'm running the latest version of iOS.  I'm dead in the water until this gets fixed. 


Currently running the latest version of everything on iPhone 11. Spotify devs need to fix this ASAP! 


Currently my Spotify won’t let me play episodes that came out before the beginning of the year for one podcast. When I hit play it pops up with “unable to play song”. All other podcasts will only play the most recent episode no matter what episode I click on. I have tried deleting and redownloading the app, doing the clean restart, every trick I can find on the internet and the issue still continues. This is on an IPhone 12 with IOS 16.3.1 with Spotify version 8.8.32.

All podcasts and episode seem to be working when on my laptop. The issue only seems to be in the IPhone app. 

I also tried the internet version on my IPhone and all play buttons for every podcast episode what greyed out. 


I’m having the same issue. Running version Tried multiple log outs and clean reinstalls and it doesn’t work.


we need a fix!