Announcements

Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

"Connect to WiFi and wake device" when trying to use Alexa speaker group

Plan

Premium

Country

USA

Device

MacBook Pro 18,1 + iPhone

Operating System

Latest for both

 

My Question or Issue

Spotify Connect + Alexa has always has major issues and never reliable. Today's flavor of the week is this. All the devices in the group are awake and respond to me. The device tab seems to flip flop between these two:

Screenshot 2023-09-11 at 12.18.58 PM.pngScreenshot 2023-09-11 at 12.23.29 PM.png

Hey folks,

 

Apologies for the lack of updates on our end.

 

We'd like to report this to our tech team so for anyone experiencing this, please provide the exact models of the affected devices in addition to the details requested by @Ivelina (see below):

  • Does the issue only happen with newly added devices?
  • Does it happen with groups or individual speakers?
  • Are there other Spotify users in the household using them?
  • What have you tried so far in order to fix the issue?

Thanks for your help!

Comments
Joan

Hi there @Vexir,

 

Thanks for reaching out. We'd be happy to help with this in any way we can. Could you tell us in a little more detail as to what exactly the behaviour is and what steps you took to get it? Does disconnecting and reconnecting the affected devices help? Try that if you haven't already.

 

Let us know how it goes.

Vexir

Resetting a device does help, but only temporarily. A few days later and it’ll end up back in a state like this, or it’ll just not play as part of the group. 

Dian

Hey @Vexir,

 

Thanks for the reply.

Have you tried resetting the devices to their factory settings and rebuilding the connection from the ground up, preferably using a different internet connection?

Keep us posted on the results.

 

Cheers!

efanmar

Same problem. Please help

irishlangley

Who has multiple internet connections in their home?

efanmar

πŸ™‹β€β™‚οΈπŸ™‹β€β™‚οΈπŸ™‹β€β™‚οΈ

hectorrositas

I've also been facing this problem on MacOS and Android (Galaxy S21) both the most updated software. The issue is on the "Connect a device feature" where an Echo Dot Gen 4 appears as "sleep" as it asks you to "Wake device and connect to the internet". When connecting to other devices it wakes them up and some like the PS5 even have a "Allow turn on from Spotify in energy saving settings", so I'm sure it can wake devices up. I've checked and the speaker is connected to the internet and functions correctly. My get around to this issue is that I have to tell it "Alexa, play music" and THEN it will become available in my devices list on spotify.

tibowski

Similar thing happened to me. I have configurete one more new echo dot, then I changed the default name of it and the old one remains. It says "connect to wifi and wake device". Someone have a solution?

fudge3

Ive just got a new device and this is happening to me too, it works if i speak to it but as soon as it disconnects its back to the same status

efanmar

This issue is really frustrating. 

Please help us πŸ˜ž