Announcements

Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

"Connect to WiFi and wake device" when trying to use Alexa speaker group

Plan

Premium

Country

USA

Device

MacBook Pro 18,1 + iPhone

Operating System

Latest for both

 

My Question or Issue

Spotify Connect + Alexa has always has major issues and never reliable. Today's flavor of the week is this. All the devices in the group are awake and respond to me. The device tab seems to flip flop between these two:

Screenshot 2023-09-11 at 12.18.58 PM.pngScreenshot 2023-09-11 at 12.23.29 PM.png

Hey folks,

 

Apologies for the lack of updates on our end.

 

We'd like to report this to our tech team so for anyone experiencing this, please provide the exact models of the affected devices in addition to the details requested by @Ivelina (see below):

  • Does the issue only happen with newly added devices?
  • Does it happen with groups or individual speakers?
  • Are there other Spotify users in the household using them?
  • What have you tried so far in order to fix the issue?

Thanks for your help!

Top Answer
gctso
Newbie

Hey guys, I have figured it out for my situation. Spotify didn't recognize the device group "Everywhere" from which I want to play, but it recognized the individual devices in that group. The third method below worked for me. I changed from "Everywhere" to "Upstairs", and the recognition of "Upstairs" was instant. I could have kept using "Upstairs", but I still wanted to name "Everywhere" so I changed back to "Everywhere". It is stilling working.

 

There are three things you can try. First two things already mentioned previously in this thread.

1. Sign out Spotify from everywhere. Do so on desktop site.

2. Unlink and link Spotify in the Alexa app.

3. Change the name of your Alexa group (remove the old group if it lingers after you change the name).

 

I imagine the first two methods would work for greyed out individual devices and the first method would work for greyed out speaker group.

Comments
AleGonzalez

Nothing works… except the advise from the guy who said to ask “Alexa play music” 🤷🏻‍♂️

MihailY

Hey @AleGonzalez,

 

Thanks for reaching out.

 

Can you please confirm you've tried @gctso's solution? If yes, and the issue persists, please send over the info requested in the status update post.

 

Cheers,

thetrvekvlt

Same issue here as poster above. All updated, fairly new phone, haven't had issues, just today my devices don't appear anymore, Amazon speaker groups also don't appear. I have used android auto today, just as I did before. Really annoying and know bug.

thetrvekvlt

The main issue is that Amazon Alexa speaker groups have been completely obliterated from the app. As they are not single devices but groups they cannot be selected anymore. This is really a horrific development or, as you may call it, new "feature". I don't see why I wouldn't switch to Amazon music now.

1112325

I have the same issue and I've tried everything already suggested. I have no idea why it stopped working from today. Neither the app and the desktop version can play music on my Echo dot 5th generation. Please help

rhosk

Plan

Premium

Country

USA

Device

ALL

Operating System

ALL

 

My Question or Issue

It seems that Alexa (music) Groups don't show up in Devices any longer. Just FYI. I believe the Alexa App just updated, so not sure if it's related to that or not. 

 

Edit: Disregard, it eventually fixed itself. Not sure if it was "Network", "Alexa", or "Spotify", but I guess you just need to be patient.

akorhan

This problem exists in Spotify more than 2 years I guess. I have echo 4 5 gen echo dot 5 gen and echo studio. All have similar issues from time to time. A workaround you can select the unavailable echo from Alexa app 

MihailY

Hey folks,

 

Is there someone who has tried the solution in the Top Answer comment and is still experiencing the issue? If yes, please post the info requested in the status update.

 

Thanks!

gwenolechenouard

Hi,

 

Plan Premium

Country FRANCE

Device PC Windows 11 (last updated) + Samsung A52s (Android 13)

2x Echo dots gen 5 (grouped)

 

Does the issue only happen with newly added devices? : i don't know
Does it happen with groups or individual speakers? groups
Are there other Spotify users in the household using them? no

 

The problem is: when I tell alexa to play spotify on my speakers group (voice command "Alexa, play Spotify"), the music is played but:

 

1- the group AND the 2 echo dots are grey on Spotify windows app.

2- the group AND the 2 echo dots are not shown on Spotify android app.

3- most spotify api player commands returns error 500 (get playback state, transfer playback, pause playback ...)

 

To solve the problem, I need to restart both echo dots. Then everything works normally.

 

But if I stop playing spotify on the group or if I play spotify on another device, and then I wait for 15 minutes and ask alexa to play Spotify on my group name, the problem is back.

 

I tried to unlink the 2 speakers from the group (so the group is deleted). Everything works normally, even if I stop playing for 15 minutes and ask Alexa to "play Spotify" on my echo dots 5 individually.

 

I have 2 others echo dot (gen 4) at home, but they are not grouped. If spotify is playing on one of them, and if I ask Alexa to transfer to my echo dot group, the problem happens. I didn't try to link those two echo dot gen 4 in a group.

 

The first time I had this problem, is when I bought the 2 echo dot gen 5 and made a group with them.

 

If I rename the group on Alexa app, it's works but if I stop playing for 15 minutes, the problem occurs again.

 

I hope it will help developpers, cause I can't stand unplug powersupply on the 2 echo dots many times in a day....

 

Edit: my echo dots gen 5 group is a left and right speakers group

 

 

Susan_GP

Hi there folks,

Thanks to everyone who has reported the situation.

We'd like to confirm if you're still experiencing this behavior or not. If you are and you already tried the suggestions given in this thread to resolve it, make sure you send us the info we requested in the status update.

We'll be here.