Help Wizard

Step 1


"Missing Playlist" when clicking on "Go to Song Radio"






OnePlus 5T

Operating System

Android 10


My Question or Issue

When clicking on "Go to Song Radio" on any song, I get the error "Missing Playlist. The playlist is no longer valid. Please try another one". I don't have a problem with my own playlists or albums. Just with the Song Radios.

This happens on the mobile app (Android) only. On Web and Desktop this problem doesn't occur.

I tried deleting cache/data. I tried reinstalling the app. There is no issue with the internet connection (everything else works as expected)


Please help, since the app becomes a bit useless for me without that feature.



Hey folks,


Thanks for your patience while we looked into this issue.


We’re happy to say that this should now be fixed for everyone! Just make sure your app is updated to the latest version.


If you're still having trouble, make sure to post a new thread in the relevant help board here.




Hey @davidclark42,

Thanks for reaching out about this in the Community!


Can you try the following:

  • Connect to a different network and try starting a Radio.
  • Log in with a different account and try starting a Radio.

This will give us some insight on whether the issue is account related.


We'll be on the lookout for your reply.




Hi @marin_azur88,

Thanks for reaching out about this in the Community!


We'd recommend running a clean reinstall of the app, following the steps in this Guide exactly.


If starting radio doesn't work after that, can you try to log in with a different account on your Android device and start a Radio. This will help us check whether the issue may be account related.


Keep us posted on how you get on.


Hey @MiniShred,

Thanks for reaching out about this in the Community!


The right team at Spotify is currently looking into this issue.

Can you let us know the following info:

  • Device model, OS version and Spotify version. For all the devices that Radio playlists don't work on.

This will help the investigation and the faster resolution of the issue.




I've tried multiple networks, as outlined in my original post. (no difference in outcome)


And I checked the mobile app just now, and the playlist functionality is working correctly, so whatever the problem was, it appears to have resolved itself. 

Status changed to: Under investigation

Hey folks,


Thanks for reporting this issue to us.


We’ve passed your info on to the relevant team, who are currently looking into it.


If you’re experiencing this issue, make sure to click +VOTE and Subscribe to the thread to be notified of any developments.


Could you also make sure to provide us with the following info, if you haven’t already:

  • Device + OS version
  • Exact Spotify version
  • Troubleshooting steps that you've tried so far

Thanks! We’ll keep you posted and let you know as soon as we have any updates on this.




Hello Alex,


some minutes ago I tried the song radio option again and now it's working properly.


Anyhow when it can helps you for similar or further problems here are the missing data.



Huawei P30 pro VOG-L29

OS version


Android 10


Spotify version


Thanks for your fast answer and support.







I also tried it again now and it works!


I checked today and the Radio feature has started working again 🥳


I'm still on the same version of Spotify as before.


I'm still getting the same issue with a different message when attempting to load some Album Radio Stations. This just happened when trying to load a Radio Station from Pirate Radio (album):


"This playlist was deleted

Remove the link from Your Library?



Running Spotify Version on iPhone 12 iOS 14.4.2

Just completed clean reinstall. Issue persists.


Issue also occurs on Mac with different message:


"Couldn't find that playlist

Search for something else?"


Running Spotify Version on 2011 Macbook Pro OS 10.13.6

I pay for Spotify Premium with Hulu. This is really annoying. Radio Stations are my main way of listening to Spotify.


i seen a comment aboout this issue they were thinking it was caused due to removing a release that was on there