Artist names showing in Japanese

Reply

Artist names showing in Japanese

dawnclover
Newbie

Hi,

 

I'm from Europe, and my account is also European (share a family account with my parents and some cousins), but I moved to Japan a couple of months ago for work for a while. Spotify worked marvellously for months, until suddenly, since yesterday, some artists started showing up with Japanese characters, which makes it very hard to scrobble (I use last.fm a lot, and the direct connection to last.fm was one of the reasons I got a Premium subscription to Spotify) and it kind of ruins the concept of maintaining music charts.

 

For example:

David Bowie >> デビッド・ボウイ
Sigur Rós >> シガー・ロス

 

Funny thing is, at the top of the artist page, it still shows the normal name. I don't have access to any Japan exclusive music, which is fine, as my account is European, so I don't know why I am getting this side effect? A coworker, also from Europe, does not have this problem (at least for now).

 

Is there any way around this?

 

As a side thought:

I do not understand this choice of changing the names to Japanese for the Japanese market anyway. One of my Japanese coworkers was annoyed by it as well (he also uses last.fm). It is also a weird decision because of the connection to that service. If a band has a name with Roman characters, don't change it to Japanese characters... same the other way around, if the artist is Japanese, don't romanize the name, it should always display the original.

6 Replies

Re: Artist names showing in Japanese

ddvindas
Regular

any solution? im having this same issue

Re: Artist names showing in Japanese

kimuchibox4000
Newbie

+1, would also like to know how this behavior can be changed. I already tried chaning my language settings (Mac OS Desktop app).

Re: Artist names showing in Japanese

ddvindas
Regular

im having the same issue in both mac, web and in my android device....wth is going on?

Re: Artist names showing in Japanese

ddvindas
Regular

ok, now its only happening on the browser, but it is extremely anoying because almost every artist is in japanese!!
COME ONE SOMEONE HELP!!!

Re: Artist names showing in Japanese

ddvindas
Regular

I finally got the solution, when the problem is showiong up only on the browser version, and you are using google chrome do this:

  1. Go to configuration and disable synchronization, then close Chrome.

  2. Search for the google chrome settings file. Mac: User>Library>Application Support>Google>Chrome>Default
    (fon windows search a guide to find the google chrome configuration file)

  3. Search for a file caller "Preferences" and open it with a text editor.

  4. Search for "lan" and find language, next to it you will find all the installed languages, leave only the ones you need and leave the default as first one, then save.

  5. Open up Google Chrome and go back to your sync settings,then go to the managed syncronized data in google control panel (https://chrome.google.com/sync?hl=es-419)

  6. Go down and click on the reset synchronization button, it will log you out of your chrome profile/account

  7. Go back and relog into you Chrome profile/Google account, reenable sync and sync all data.

That should do it, worked for me.

Re: Artist names showing in Japanese

v50p-_cc3di3
Newbie

Have the same issue but on my phone (iPhone 7) help pls

SUGGESTED POSTS