[BB] Blackberry 9700: some downloads interrupted halfway during playback

Reply

[BB] Blackberry 9700: some downloads interrupted halfway during playback

Pieter
Regular

On my European blackberry 9700 some tracks will only play a couple of seconds or are interrupted halfway through. I've deleted and re-downloaded the app multiple times and also tried syncing in high and low quality through WIFI (I don't use 2G/3G for syncing or streaming). On iPod the syncing and playback of the same tracks and playlists work without problems.

26 Replies

Richard
Roadie
Hey Pieter, welcome to the Community.

Please check your APN (Access Point Name) settings to sort out any connection problems. To get to the APN setting:

OS 5: Options » Advanced Options » TCP/IP
OS 6/7: Options » Device » Advanced System Settings » TCP IP

For example, with o2 'wap.o2.co.uk' won't work. You'd have to use 'mobile.o2.co.uk' instead. Be careful though, as using the 'normal' APN might incur a charge from your mobile carrier.

After changing the settings, you'll need to reinstall Spotify since this data is saved in the app.
Check out our Twitter for the latest updates on any service issues: @Spotifystatus

Problem solved? Click 'Accept as solution' to make it easier to find for others!

New to the Community? Check out our Community newbie tips

Pieter
Regular

I'm not sure what to do. With OS v5, I checked out the advanced options/TCP/IP link. But it asks to check " enable APN" box and then asks for a username and password. Since I only use WIFI to stream and sync for offline use, I'm not sure how your response applies to my situation. So: problem not solved.

Richard
Roadie

Ah, ok. I wasn't entirely sure that would work either to be honest. We don't see a lot of Blackberry connection problems so I'm relatively inexperienced at dealing with them. In any case, let's keep trying.

 

Check under Options » Device » Application Management

Choose the Spotify app, then Edit Permissions. Connections settings are under the Connection tag. See if there's anything there that might be preventing the app from connecting properly.

 

Spotify uses port 4070 for its connection so this might be being blocked. But we do try 443 and 80 as well. If this doesn't mean much to you then I'd recommend just resetting your wireless router as an initial first step to try.

 

How long have you been using the app? Are the problems caused by anything in particular, that you can see?

 

Check out our Twitter for the latest updates on any service issues: @Spotifystatus

Problem solved? Click 'Accept as solution' to make it easier to find for others!

New to the Community? Check out our Community newbie tips

Pieter
Regular

my settings are: Connections: Allow; Interactions: Custom (I cannot change this); User Data: Allow.    I've started using this app since last week.

Richard
Roadie
Ok, did you try the router reset? You might need to set up things to allow Spotify access.

To test this out you could try connecting on a different network. Is this at all possible?
Check out our Twitter for the latest updates on any service issues: @Spotifystatus

Problem solved? Click 'Accept as solution' to make it easier to find for others!

New to the Community? Check out our Community newbie tips

Pieter
Regular

It seems the problem is solved after the reset. Also, it was ok on another wifi-network. So thanks for the magic Smiley Happy

Pieter
Regular

It seems the problem is back. Exactly the same track jams after 6 seconds both in stream and sync mode.

Richard
Roadie
Is it just that track in particular, or any song?
Check out our Twitter for the latest updates on any service issues: @Spotifystatus

Problem solved? Click 'Accept as solution' to make it easier to find for others!

New to the Community? Check out our Community newbie tips

Pieter
Regular

It's a couple of songs, but always the same.

Pieter
Regular

Som some songs are ok, some aren't

Richard
Roadie
Do you have any songs synced offline? Perhaps these could be interfering somehow.
Check out our Twitter for the latest updates on any service issues: @Spotifystatus

Problem solved? Click 'Accept as solution' to make it easier to find for others!

New to the Community? Check out our Community newbie tips

Pieter
Regular

Yes, I do have songs synced offline. But the particular songs don't work in either streaming or synced off-line mode. Can it be that there is aninterference from other devices(iPods)  I use for my Spotify account?

To summarize what I've done: I've repeatedly deleted and reinstalled the app and I've switched wifi networks also and I've reset the router of 1 of those networks. And ithe songs are ok on iPod.

Richard
Roadie
It's possible, though I don't think it should be causing an issue. Still, we could try resetting the device information on your account (you've currently got a blackberry and two iOS devices registered).

Doing so will however mean you'll need to resync your offline playlists. Would you like me to give it a go?
Check out our Twitter for the latest updates on any service issues: @Spotifystatus

Problem solved? Click 'Accept as solution' to make it easier to find for others!

New to the Community? Check out our Community newbie tips

Pieter
Regular

Yes please

Richard
Roadie
Ok done, let me know how you get on now.
Check out our Twitter for the latest updates on any service issues: @Spotifystatus

Problem solved? Click 'Accept as solution' to make it easier to find for others!

New to the Community? Check out our Community newbie tips

Pieter
Regular

still doesn't work either streaming or synced off-line. Same problem persists

Richard
Roadie
Well that's annoying, so we're not really much closer to a fix at this point. But we'll keep trying (thanks for being patient with this!)

Reading back over the thread it seems that something might be going on between the device and the particular wifi network you are on. You said it worked ok on another network and worked ok for a little while after a router reset.

Does your router have any kind of internal firewall built in that might be stopping the connection? That said, this shouldn't cause an issue for playing tracks already synced to the device.

So I should also ask if you're running any other apps at the same time as Spotify. Anything that might cause a problem?
Check out our Twitter for the latest updates on any service issues: @Spotifystatus

Problem solved? Click 'Accept as solution' to make it easier to find for others!

New to the Community? Check out our Community newbie tips

Pieter
Regular

Normally I'm not running any other apps. And I've tried on 2 other wifi networks to reset, resync, re-install and the problem continues. Could you maybe reset the iOS devices also?

 

Even if I delete the jammed song, search for it again and the play it (before and after syncing), it jams as before. I've also tried to stream and sync i high and low bandwidth to no avail.

 

The only reason I can think of is that the nr of devices using the same account somehow leads to problems. But then it's strange it's only with Blackberry (although it was the last device after the iOS devices so maybe there is something in there).

Richard
Roadie
Yesterday I did remove all the devices registered to your account, and today you're back to the Blackberry device and two iOS devices. But I don't think that is the issue any more.

One more question I should ask before I run out of ideas: when you're reinstalling the app are you deleting the old user files first? Simply redownloading the app won't clear out the old files, which I think could be causing cache issues of some kind.

Check out our Twitter for the latest updates on any service issues: @Spotifystatus

Problem solved? Click 'Accept as solution' to make it easier to find for others!

New to the Community? Check out our Community newbie tips

Pieter
Regular

How do I delete those files?

SUGGESTED POSTS