Desktop App not working

Reply

Desktop App not working

Deno_NR
Regular

Plan

Premium

Country

Brazil

Device

Acer Laptop

Operating System

Windows 7 SP1

 

My Question or Issue

For the past two weeks, my Desktop App has not been functioning correctly. The issue is that when I press the play button, it won't play the song, the app will proceed to stop loading any albums or playlists and when I close the window and try to open it again an error message saying "The Spotify application is not responding" pops-up. The weirdest part is that some rarer days it works flawlesly but in most other days it doesn't. This issue is exclusive to the Desktop App; the Web Player and Mobile App are working normally.

17 Replies

Jeremy
Moderator
Moderator

Hi there @Deno_NR,

 

Thank you for reaching out to us here in the Community. We're happy to help.

 

Can you perform a clean reinstall of the app? This will make sure there's no old cache files causing this.

 

Another useful step to try is to remove any lines of your host file. you can do that by following the steps bellow:

  1. Open Notepad as an administrator (right-click - Open as Administrator)
  2. go to File - Open and navigate to C:\Windows\System32\drivers\etc
  3. Choose "All Files" instead of "Text Documents" next to the File Name box. You'll see a handful of files. Pick hosts and click on Open
  4. When the file is open, you will see a block of text with # in front of each line and might see entries like 0.0.0.0 website.com127.0.0.1 website2.com
  5. Check for any entries with Spotify in the address. Examples may look like: 0.0.0.0 weblb-wg.gslb.spotify.com0.0.0.0
  6. If you do find any lines with Spotify, please remove them
  7. Save your changes and restart Spotify

Let us know how it goes.

 

Take care 🙂

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

Deno_NR
Regular
Performing a clean reinstall and restarting my device solved the issue, thanks so much! 😄

Eni
Moderator
Moderator

Hey @Deno_NR

 

Fantastic news! Give us a shout if it starts misbehaving again; we're always here to help. 

 

Have a great day 🙂

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

Deno_NR
Regular

It stopped working again 😧

 

It started behaving in the same way as it was before. I tried doing what you said to the host file, but I don' even have a host file in my computer to begin with, what should I do?

Ver
Moderator
Moderator

Hey @Deno_NR,

 

Thanks for keeping us in the loop.

 

Could you try running the app as an administrator to see if there are any changes?

 

It's also a good idea to try running a reinstall while in a safe mode. Does this make a difference?

 

Keep us posted.

VerModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
"Difficult roads often lead to beautiful destinations." ―Zig Ziglar

Deno_NR
Regular

Performing a Clean Re-Install while on Safe Mode seems to have fixed it so far. I am going to give this a few days and if anything happens until then I will let you guys know

Jeremy
Moderator
Moderator

Hi there @Deno_NR,

 

Thank you for your reply and confirmation.

 

We're really glad to hear that everything works as it should for you again 🙂

Let us know if we can help you with anything else.


Take care!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

Deno_NR
Regular

It already stopped working lol

Jeremy
Moderator
Moderator

Hi again @Deno_NR,

 

Thank you for getting back to us 

 

Can you confirm if you you tried running the app as an administrator?

 

On another note, how does the app work for you if you download it form our website here?

 

Keep us posted.

 

Cheers!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

Deno_NR
Regular

I did run the app as an administrator, I've tried downloading it from the website you recommended, performed a clean reinstall both out and in safe mode and the results were the same, it worked fine up until I closed the app and opened it again, when the same issue started to happen

Alex
Moderator
Moderator

Hey @Deno_NR,

 

Thanks for the reply.

 

There are a few more steps you need to test out:

  • Try logging in with another account. You can create a free account for test purposes.
  • Try starting the app in Windows 8 Compatibility mode.
  • Try connecting to a different network such as a mobile hotspot

If none of this helps, please upload a screenshot of the errors you encounter. 

 

Most likely the issue is related to how the app is managing it's cache on your hard drive, since it was working well for some time after the reinstall in safe mode.

 

Keep us posted.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“With freedom, flowers, books, and the moon, who could not be perfectly happy?” ― Oscar Wilde

Deno_NR
Regular

Nope, none of these worked

 

Keep in mind that even though it shows that the song is playing, it actually isn't playing anything and that error only shows after I try to play a song. By the way, sorry if this wasn't clear enough, I'm just really bad with words lol

Screenshot_2.png

Novy
Moderator
Moderator

Hi @Deno_NR

 

Thanks for keeping us in the loop. 

 

Just to confirm, are you still experiencing these issues when you log in to your account using a different device?

 

Also, could you send over the exact app version you're currently running?

 

We'll be on the lookout.

NovyModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
"Music touches us emotionally, where words alone can't." -Henry Thoreau

Deno_NR
Regular

I logged in my account on my brother's laptop and it worked normally.  Also, I've never experienced any of these issues on my phone, and, just to be sure, I'm logged in the same account there. Aside from that, I'm running the version 1.1.61.583.gad060c66-a

Novy
Moderator
Moderator

Hi again @Deno_NR

 

Thanks for this info.

 

Since you had no issues with your brother's laptop, could you let us know the OS version running on his device?

 

Also, could you confirm if you were able to test this with a different account on your computer? This will help us narrow down the cause of this issue. 

 

Keep us posted.

NovyModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
"Music touches us emotionally, where words alone can't." -Henry Thoreau

Deno_NR
Regular

He's running Windows 7 Ultimate with Service Pack 1, and yes, I did test with a different account on my computer, and it also didn't work

Ivan
Moderator
Moderator

Hey @Deno_NR,

 

Thanks for keeping us posted. 

 

It seems that after all the troubleshooting steps you've tried so far the issue might be originating from the specific setup of the device in use. 

 

In this case we suggest making sure that your device is up-to-speed with any software updates available and reaching out to the manufacturer for more info. 

 

Hope this helps. Let us know if you have any questions. 

IvanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
“Music is the wine that fills the cup of silence.” - Robert Fripp
SUGGESTED POSTS