Gapless Playback Issues

Reply
Highlighted

Gapless Playback Issues

Markus-HD
Regular

Playing albums with gapless playback on alters the volume on a lot of albums. For example if i play the album Dancing Undercover by Ratt when the first song finish the second song plays with a very noticible lower volume. The same thing happens with a lot of albums i can name just a few so you can try it for yourself....

Dwight Yoakam Guitars, Cadillacs, etc. etc.

Dwight Yoakam Hillbilly Deluxe

Slayer Repentless

The Georgia Satellites The Georgia Satellites

Black Star Riders Heavy Fire

Ratt Out Of the Cellar

Ratt Reach For The sky

Fergie Double Dutchess

....and many many more

 

Those same albums play just fine with gapless playback off. It's worse on the desktop because there is no way of turning gapless playback off.

 

This issue has been going on for years now. I submitted a petittion to add a toggle to disable gapless playback on the desktop a couple of years ago but you ignored it. Lately it is getting worse as more and more albums are affected by this issue.

I hope you pay attetion this time otherwise i will be time to change to another service.

Thanks.

10 Replies

Re: Gapless Playback Issues - Status changed to: Need more info

Maria_B
Roadie

Hey @Markus-HD!

 

Welcome to the Spotify Community.

 

In this case, could you head to Settings > Playback > Set the same volume for all songs? Let us know if the same thing happens with that setting turned on.

 

Keep us posted.

MJ

Re: Gapless Playback Issues

Markus-HD
Regular

Of course the same thing happens. It makes no difference setting the same volume for all songs. I've tried all the different settings even setting the volume to quiet to preserve dynamics. The only way to solve this is to turn gapless playback off which can not be done on the desktop app because there is not such setting.

I would apreciate it very much that before you answer me back you play the album Dancing Undercover by Ratt with gapless playback on you will notice that when the first song ends the second one starts playing with lower volume. Then repeat the same with gapless playback off you will notice that it plays perfectly. There are a lot of albums that have this problem. So either you make gapless playback better or you give us an option to disable it on the desktop app. 

By the way if you play albums in shuffle mode they sound fine no issues. So i'm 100% sure that gapless playback messes the volume.

Thanks

Re: Gapless Playback Issues

Markus-HD
Regular

Of course the same thing happens. It makes no difference setting the same volume for all songs. I've tried all the different settings even setting the volume to quiet to preserve dynamics. The only way to solve this is to turn gapless playback off which can not be done on the desktop app because there is not such setting.

I would apreciate it very much that before you answer me back you play the album Dancing Undercover by Ratt with gapless playback on you will notice that when the first song ends the second one starts playing with lower volume. Then repeat the same with gapless playback off you will notice that it plays perfectly. There are a lot of albums that have this problem. So either you make gapless playback better or you give us an option to disable it on the desktop app. 

By the way if you play albums in shuffle mode they sound fine no issues. So i'm 100% sure that gapless playback messes the volume.

 

Thanks

Re: Gapless Playback Issues

SergioDavid
Roadie

Thanks for the info @Markus-HD.

 

If you haven't already done so, try following these steps on your desktop. After that, try recreating the issue to see if it persists.

 

Also, try having a friend log into their account using your device to see if the same happens for them.

 

Keep us posted.

Re: Gapless Playback Issues

Markus-HD
Regular

I’ve already done that. Clean install on a mac system and clean install on a windows system. It has nothing to do with that. The problem is that you can NOT turn gapless playback off on the desktop because the toggle was removed a long time ago. It’s very simple, either add the toggle back or improve gapless playback. I’m done trying things that i already know will not work. On Apple Music everything works as it shoud. Gapless playback works perfectly. Spotify likes to remove features all the time and i don’t understand why. I’m not surprised that Apple Music will soon have more subscribers in the U.S. 

Thanks

 

Re: Gapless Playback Issues

Alfredo
Roadie

Hey @Markus-HD!

 

Thanks for getting back to us with this information.

 

I've listened to a couple of the albums you shared and wasn't able to replicate this issue with the desktop version.

 

Just to confirm, is this happening when you use the app via Spotify Connect so you can manage it from the phone?

 

Keep us posted.



“Music acts like a magic key, to which the most tightly closed heart opens.”
― Maria Augusta von Trapp

Re: Gapless Playback Issues

Markus-HD
Regular

no i'm not using the app via Spotify Connect. So are you saying that you listened to the album Dancing Undercover by Ratt with the desktop app and you didn't notice the volume change when the first song, which is "Dance", finish and the second one, which is "One Good Lover", starts???? You also didn't notice how the volume changes between the 2nd and 3rd song in Slayer's latest album Repentless?? or The Georgia Satellites debut from 1986 between song 3 and 4??? Just to name a few. 

 

Re: Gapless Playback Issues

SergioDavid
Roadie

Thanks for the examples, but they sound fine on our end.

 

Try using Spotify Connect to control the music on your desktop with your phone. Try replicating the issue and let us know how it goes.

 

We'll be on the lookout for an update.

Re: Gapless Playback Issues

Markus-HD
Regular

gapless playback has a problem. I've tried different accounts,computers, iphone, ipad ,and all have the same problem when gapless playback is enabled some albums suffer from volume fluctuations. 

With ios devices you can disable gapless playback and solve the problem. With the desktop app there is no way of disabling gapless playback.

Frankly i'm tired of trying to explain the issue and have moderators replying that everything sounds perfect when i know 100% sure that is not. It would be so easy to solve the problem bringing back the toggle to disable gapless playback on the desktop app. You don't want to acknowledge the problem and thats ok. I will cancel my premium subscription and i'm going to Apple Music.

Thanks for everything.

SUGGESTED POSTS