Lineup Signup
Hi! We're just rearranging some Desktop boards to make it easier to find what you're looking for. Please bear with us, and we'll be done very soon.
To post a new question or issue, please go here: Desktop (Windows), Desktop (Mac), Desktop (Linux), Web Player.

I can play on home Bose speaker even though “Show local devices only” is selected

Reply

I can play on home Bose speaker even though “Show local devices only” is selected

LarterStyles
Music Fan

Plan

Premium

Country

Australia

Device

iPhone 7+

Operating System

iOS 12.3.1

 

My Question or Issue

I am currently 20kms from home (so am not connected to home wifi, see attached), however I can still see/connect to/play on my Bose SoundTouch speaker in my living room at home — even though “Show local devices only” is selected.

 

This only seems to happen when the Spotify app is already connected / playing to my Bose speaker, and then I leave the house — not when I open the app after I’ve already left the house (in which case my Bose speakers aren’t displayed, as expected). The app doesn’t appear to clear/refresh the connection until I close and reopen it.

 

This is annoying, because I now suddenly have music blasting out of my speakers at home when no-one is there.

 

I’ve repro’d this on more than device, and both have the latest OS and app updates.

24051926-80F8-49CE-8F4E-61C725FD41DF.png
0E8FBAB1-38C2-4893-8261-E62312C320E3.png
2 Replies

Re: I can play on home Bose speaker even though “Show local devices only” is selected

Jemi
Spotify Legend

Hey @LarterStyles, help's arrived. 

 

It's expected that the last device you were connected to is memorized by the app so you can quickly connect again. This is why you see the device outside of your home.

 

The speaker does not stream from the phone, but it rather fetches data from the internet which is the reason why it's possible to play from the speaker when you're not around. Keep in mind that this only applies for the last speaker you were connected to. 

 

To go around this, you either have to unplug the speaker, or have someone else connect to the speaker. Make sure to choose the right speaker when you use the Connect feature outside your home.

 

Hope that explains things, and let us know if there's anything else :)

JemiModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
"Use the force, Harry" - Gandalf

Re: I can play on home Bose speaker even though “Show local devices only” is selected

LarterStyles
Music Fan

Hi Jemi, thanks for your reply, and sorry for mine being so late.

 

Opinion: this all really seems to go against the “Show local devices only” option. I mean, the whole point of turning this option on is to prevent “remote” devices from appearing in your devices menu right?

 

My scenario is probably very common: I play some music on a third-party speaker at home, then travel, then inadvertently blast music at home the next time I open the app (hours/days later). Unplugging the speaker or have someone else connect to it don’t really seem like great workarounds!

 

My poor pets will just have to put up with getting their eardrums blasted from time to time. Thumbs down for this I’m afraid.

 

PS: I’m not the only one this happens to. My housemates have also accidentally blasted music at home when they’re out — often it “inconvenient” times or the day or night.

SUGGESTED POSTS