Mini-Player Not Showing in Wordpress

Solved!
Reply
Highlighted

Mini-Player Not Showing in Wordpress

Casual Listener

I share playlist links in my blog posts and they show up as mini players, while I'm editing and after the post is published. When I copied and pasted a playlist link today though, it only shows as the link and not the mini player. I have updated the Spotify desktop app (Mac), Wordpress desktop ass and restarted my computer to no avail.

 

Anyone else having this issue today or lately?

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Solution!

Re: Mini-Player Not Showing in Wordpress

Casual Listener

For some strange and random reason, I got it work by using the URI code. It will only show as the code in the draft blog post but when I preview my post and after it is published, it shows the centered mini-player, which is also curious, since this is also different. So I have no clue what's going on but I'm happy that I'm still able to share playlists.

View solution in original post

5 Replies
Highlighted

Re: Mini-Player Not Showing in Wordpress

Casual Listener

The same is happening for me. Podcasts, albums, and songs all seem to work fine (outputs an <iframe> tag)… it is only playlists that doesn't work (outputs an <a> tag).

Highlighted

Re: Mini-Player Not Showing in Wordpress

Newbie
  • Same for me! Even on a brand new untouched Wordpress install Spotify players no longer generate from a link. 
Highlighted
Solution!

Re: Mini-Player Not Showing in Wordpress

Casual Listener

For some strange and random reason, I got it work by using the URI code. It will only show as the code in the draft blog post but when I preview my post and after it is published, it shows the centered mini-player, which is also curious, since this is also different. So I have no clue what's going on but I'm happy that I'm still able to share playlists.

View solution in original post

Highlighted

Re: Mini-Player Not Showing in Wordpres >> Screenshot of issue

Casual Listener

Screenshot from Wordpress backend showing the podcast link working but the playlist link not. The output is exactly the same on the front end.

Screenshot 2020-05-18 at 13.49.02.png
Highlighted

Re: Mini-Player Not Showing in Wordpres >> Screenshot of issue

Newbie

Having same/similar issues with playlist links and embed. 

 

I'm not sure why this makes a difference, but the newer (I guess) style of Spotify playlist links seem to work more reliably than the type we've been using.
 
 
vs. 
 
 
The embed on this page "should" work - https://waterfire.org/about/music-of-waterfire/october-5-2019-waterfire-music-program/ - but it doesn't.
 
Annotation 2020-07-07 112119_b.jpg
Annotation 2020-07-07 112119.jpg
Annotation 2020-07-07 112119_c.jpg
SUGGESTED POSTS