New Webplayer not working

Reply
Highlighted

Re: New Webplayer not working

Rock Star 16
Rock Star 16

Hey @ElvisPolanski!

 

See this thread's Solution part.
If commenting out Spotify's and fastly's didn't work yet, try commenting out all the entries (except for those you know, if you use that file for something).

 

Let me know how it goes! 🙂

 

Seb

SebastyRock Star 16
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.
Highlighted

Re: New Webplayer not working

Casual Listener

Your "solution" does nothing.
I even tried using an agent switcher. Tried setting Firefox, IE, etc. No difference.
No add-ons.
Flash enabled for Spotify.
FIrefox 57+ (Quantum)
Pressing Play doesn't do anything.
Works fine in Chrome, but Chrome is awful for other reasons.

Highlighted

Re: New Webplayer not working

Rock Star 10
Rock Star 10

Hey there!

 

Firstly, sorry for the late reply. 

 

I’m sorry to hear you are still experiencing issues with the Spotify web player. Just to confirm, the issue is that no dogs play, when you click play nothing happens? And that you have also tried on several other browsers? If you could confirm that, just so we’re on the same page. 

 

Thanks,

Tom

TomRock Star 10
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.
Highlighted

Re: New Webplayer not working

Regular

After some self research I found the cause:
The problem is with a flag in Firefox.
In About:config there is a flag called "media.autoplay.enabled"
By default is true
However, due to so many **bleep** websites adding auto play videos and autoplay ads that blast the user without their consent, most people change that flag to False.
The way it's SUPPOSED to work, is the user has to hit the PLAY button videos etc. for the media to play.
For some reason, the spotify webplayer is not accepting the play button as activation.
WIth this flag at true, the player works.
But, myself and many others refuse to have this flag on true because of stated above reasons.
Chrome has a similiar flag, (they call it "user gesture) but because of their ad network and revenue, it doesn't work on most sites anyway because crappy sites found a loophole around Chromes implemention.
I refuse to go back to using a web that Chrome decides for me.
So, is there a way the web player can be adjusted to allow activation by user gesture?

Highlighted

Re: New Webplayer not working

Regular

"The problem is with a flag in Firefox.
In About:config there is a flag called "media.autoplay.enabled"
By default is true"

 

Agreed.  When I changed this FF setting back to the default of 'true' Spotify worked for me. But that was not a solution because I needed the flag to be 'false' for all the other web sites that insist on auto-playing junk.

 

My workaround since my posts above six months ago has been to use a different browser solely for Spotify and I use FF for everything else.  Slightly annoying but it got around the problem.

 

Highlighted

Re: New Webplayer not working

Casual Listener
Agreed.
Having to use another browser for one website/app is ridicules.
SUGGESTED POSTS