Saved songs from specific artist not shown in library (anymore)

Reply

Saved songs from specific artist not shown in library (anymore)

ubbenmaster
Regular

Hi,

before the last update I went to: Library -> Artists -> "Name of Artist" and found all the songs I saved. That was great.

 

Since the last update I don't see these songs anymore in my library (when selecting an artist). Instead, I am directed to the artists spotify page with all the sections like "favorite songs", "singles", "albums", etc. 

 

This is absolutely uncomfotable, because I collected songs from different artists for a couple of years. When I chose an artist from my library, I had all these songs in one place - like a playlists. With the removal of this feature, it seems like I have to create a playlist for any artist now. 

 

Please change this back - it's abolutely annoying.

 

 

Plan

Premium

Country

Germany

Operating System

Windows 10, Android 9

4 Replies

Re: Saved songs from specific artist not shown in library (anymore)

Moderator
Moderator

Hey @ubbenmaster.

 

Thanks for getting in touch and providing us with feedback.

 

Your songs are still in your library under Songs and Albums. The Artist section will now display the Artists you follow and link you to an Artist page.

 

Be sure to vote for this idea if you are not happy with the recent changes in the library works.

 

Let us know if you have further questions.

 

Have a nice day.

GuidoModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

Re: Saved songs from specific artist not shown in library (anymore)

ubbenmaster
Regular

Thanks for your reply. I voted for your linked topic.

 

I am really unhappy with the recent changes. Getting to the artists page is (and always was) more comfortable by typing the artist's name to the search field. Why should I navigate through my library then? That's absolutely not comprehensible.

 

Going to Library -> Songs is also very fiddly, because there is no filter option at all. First, I have to sort my songs by artist -> then navigate through all my songs (more than 1500!!) to hear the saved songs. If I want to shuffle through them, I even have to create a new playlist. That's absolutely annoying!

 

Please take back that feature!

Re: Saved songs from specific artist not shown in library (anymore)

Moderator
Moderator

Hey @ubbenmaster.

 

Thanks for getting back in touch and your feedback regarding this.

 

Keep in mind that you can view only your downloaded saved songs by heading to Your Library > Playlists > Liked Songs > tap the three dot menu on the top right corner > select Filter downloaded songs. You can then tap on any song you'd prefer and toggle shuffle on to listen from your downloaded songs.

 

If you'd like to listen to all downloaded songs from a certain artist's Album, you can always make sure to save that album and then download any of the songs you'd like available offline. This way, it should show up under Albums. You can then head to Your Library > Albums > tap the three dot menu on the top right corner > select Filter downloaded albums.

 

Let us know how you get on :)

KaterinaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
"Kindness is the language which the deaf can hear and the blind can see." - Mark Twain

Re: Saved songs from specific artist not shown in library (anymore)

bluntcoolkid
Casual Listener

I’ve been having this same issue. I’ve saved Gym Class by Lil Peep and it keeps saving and showing this song called Guys Don’t Cry by Lucy Fer, instead of Gym Class by Lil Peep.  This is a bug that needs to get fixed.

SUGGESTED POSTS