Songs keep skipping by themselves. HELP.

Solved!
Reply

Songs keep skipping by themselves. HELP.

vybz
Casual Listener

I'm using a free plan and using a HP pavilion Chromebook on Chrome OS 65. 

I cannot download the actual spotify player because im on Chromebook so i use the web player a lot but recently whenever a start a song, it skips after 2 second, then again and for every song. It just keeps skipping after a couple seconds. 

I've went through a lot of threads but they were all from around 2014 so i created a new one, if there is a new answer.

1 ACCEPTED SOLUTION
Solution!

Elena
Moderator
Moderator

Hey there folks,

 

Thank you for your posts.

 

We're sorry to hear you're still having trouble with with. We can confirm that this ongoing issue should now be fixed, so your issue might be caused by something else.

 

Make sure to take a look at the supported browsers listed here. If you've checked that would you mind letting us know what troubleshooting steps you've done?

 

We'll have an eye out for your reply 🙂

 

Cheers!

ElenaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

View solution in original post

121 Replies

Ienz
Music Fan

Sorry, I cannot see that the issue is fixed. It still does not work on my PC's web player (Chrome, already tried Incognito tab; on MS Edge the web player does not seem to work at all). Please fix it or advise us how to fix it, otherwise I see no point in maintaining my Spotify subscription. Thanks! 🙂

Mihail
Moderator
Moderator

Hey @Ienz,

 

Thanks for reaching out to the Community.

 

We'd like to try some of the troubleshooting  steps suggested previously in order to get to the bottom of this, since the ongoing issue on Chromebook was resolved a while back. Could you let us know if the issue persists when you use another device altogether? It would be great if you could also give it a go with another account. You can create a free one with another email here. If it works on the new account you can copy your playlists from the old account using these steps . 

 

It's also a good idea to check if you observe the same under a different network. If it works with another connection, it's best to contact the service provider of the original network for more information.

 

Let us know if that helped, we'll keep an eye out for your reply.

MihailModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music is a language that doesn’t speak in particular words. It speaks in emotions, and if it’s in the bones, it’s in the bones.” - Keith Richards

Ienz
Music Fan

Hello Mihail,

 

Many thanks for your swift reply. 

 

The problem only happens on my work PC, but not on other devices that we use within our Family Account, e.g. iPhones, iPads or a Sonos player.

 

Playing Spotify on my PC used to work every day for years, but ceased to work last week. I have tried Chrome and MS Edge - no success. I have tried both WiFi and LAN connection - no success. I have set up a new account - no success, tracks keep skipping in the web player.

 

Frankly, I am quite surprised that, according to your Support Forum, this issue appears to persist since many years without being fixed by Spotify.

 

So, what would you suggest?

 

Best regards,

Ienz

 

Alex
Moderator
Moderator

Hi there @Ienz,

 

Thanks for the info.

 

Can you try to remove any entries that contain Spotify from the Host files on your PC if your system administrator allows it.

 

Have a look at the Solution by @Sebasty in this Thread.

 

These can often cause playback issues with the Web player.


Also can you let us know if tracks are skipping if you're connected to a mobile Hotspot on your work PC?

 

Let us know how you get on with this.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“With freedom, flowers, books, and the moon, who could not be perfectly happy?” ― Oscar Wilde

Ienz
Music Fan

Hello Alex,

 

Thanks for the hints. I have checked the host files but found no entries containing Spotify.

And I have tried both WiFi as well as a LAN connection for my PC.

 

Alex
Moderator
Moderator

Hi @Ienz,


Thanks for the reply and for going through this troubleshooting process with us.

 

Can you clarify if you've tried connecting your work PC to another network like a public network or you've only tried with Wi-Fi and Lan on the same network?

 

Sometimes system administrators may enable certain processes which hinder the performance of apps like Spotify.

 

We'll be on the lookout for your reply.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“With freedom, flowers, books, and the moon, who could not be perfectly happy?” ― Oscar Wilde

Ienz
Music Fan

Hello Alex,

 

No, currently I can only connect my PC to my own network (I am in home office ;-)). 

 

By the way, I have to access the internet through my employer's VPN (Cisco AnyConnect Secure Mobility Client). This might be causing the problem. Still, it used to work for many years.

 

Having said this, I guess that this bug affects many users across the globe, so it might be in Spotify's utmost interest to fix it so people don't switch to your competitors.

 

Thanks & best regards!

 

Ienz
Music Fan
Hello, any news on this? The bug still persists...

Ienz
Music Fan
Is there anybody out there?

Novy
Moderator
Moderator

Hey there @Ienz

 

Thanks for getting back to us and apologies for the delay.

 

Would you mind sending us your device's make and model?

 

Also, could you let us know if you're able to use the web player with no issues when you disconnect from the VPN?

 

We'll keep an eye out for your reply. 

NovyModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
"Music touches us emotionally, where words alone can't." -Henry Thoreau

Ienz
Music Fan

Hi @Novy,

 

I have an HP EliteBook 830 G5, and I cannot connect to the internet other than through my organisastion's VPN.

 

However, I think I just figured out something: If I switch the playback via "Connect Device" from "This Webbrowser (Spotify Connect)" to my Sonos player (via Spotify Connect), which is in the same LAN/WiFi network as my laptop, it works fine. But when I revert to the webbrowser, it keeps on skipping tracks.

 

Maybe this helps... many thanks in advance!

Jens

 

CarlosE
Moderator
Moderator

Hey @Ienz,

 

Thanks for keeping in touch and for all the info you've shared with us.

 

We're afraid that we don't support VPNs as they might interfere with Spotify, specially if they're from a company/organization. In this case, we suggest to get in touch with the team in charge of your network or IT department to check if there are any restrictions or blocks on their end.

 

We hope this helps. If you need anything else, give us a shout.

 

Cheers.

CarlosEModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

Ienz
Music Fan

OK, thanks, this might be the root cause. Previously it used to work with my organization's VPN, but now either they have changed something or Spotify did. 

 

But I guess there is nothing we can do at the moment, so let's close this thread.

 

Thank you for your support anyway!

 

sophia2405
Visitor
Same. I started having this problem on Monday, 10/05/2020

Elena
Moderator
Moderator

Hey there folks!

 

Welcome to the Community and thanks for reaching out about this.

 

We have received a few other reports about the web player skipping on Chromebooks and we're currently looking further into this.

 

Feel free to leave your details and +Vote here. Hopefully we'll have more info on this soon!

 

Keep an eye on the page for any updates.

 

Let us know if there's anything else we can help out with 🙂

ElenaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

Elharp6520
Casual Listener
It seems to be fixed.

QueenFan
Regular

It working now!! Thank you, Spotify!

ashaelaj
Casual Listener

It's fixed! Thank you guys!!!

palmerbrianna26
Visitor

The same thing is happening to me that I have read in all of the comments. I have tried everything but it keeps skipping songs and then going to a commercial and then taunts me by playing nine seconds of a song and then stopping. This is getting ridiculous, I hope that the Spotify team will be able to fix this very soon this has been happening for the last two weeks, and I am not the only one that this has been happening to. I am on the web player and am using a Chromebook. I have tried going on both  guest and incognito mode with no luck either way. I have talked to both friends and family members who have all had the exact same problem, it shouldn't be taking this long to fix, everyone that I have talked to myself included is frustrated that the problem is going on and no one seems to be able to do anything about it. This is not a problem on our end this is a problem on yours and I think that we all have been waiting patiently enough.  🙂 

QueenFan
Regular

I've been having the same problem! Unfortunately, I can't download it, because my computer isn't hooked up to a Google App store. I guess I'll have to use YouTube for the time being until this problem gets figured out.

fearmakasu
Casual Listener

Here is what you do, go onto the spotify app on your chromebook and click on the 3 dots on the right hand corner, then click on app info. Once you do that, click allow protected content. and then refresh the app. Now it should be working! If youre on the web player on chrome browser then just press on the lock symbol on the left hand side of the url on top, then allow protected content right there. Refresh. Now it should be working for you too!

SUGGESTED POSTS