Lineup Signup
Hi! We're just rearranging some Desktop boards to make it easier to find what you're looking for. Please bear with us, and we'll be done very soon.
To post a new question or issue, please go here: Desktop (Windows), Desktop (Mac), Desktop (Linux), Web Player.

Spotify Connect on Echo Dot stutters, choppy.

Reply
9 people liked this

Spotify Connect on Echo Dot stutters, choppy.

SmileyKitKat
Casual Listener

 

Alrighty, so here is my issue. 
I use my Echo Dot often as a speaker for Spotify, and last week I began to notice stuttering when it would play songs. It has since gotten way worse, as the song cuts out constantly-it's gotten quite infuriating. 
The Echo can answer anything else without failure or cutting out- and it appears this is an issue with other users and has been in the past.


Anyone else having this issue? 

30 Replies

Re: Spotify Connect on Echo Dot stutters, choppy.

Moderator
Moderator

Hey @SmileyKitKat.

 

Sorry to hear that your speaker isn't playing back fluently. Could you find out if your speaker is running the most recent Firmware? Make sure it's within good range of your WiFi router. If you use the 5Ghz band, the range can be less, especially when the signal needs to come from a different room. 2.4Ghz lacks the speed but is better with range. So you could try switching between te two hands to see if that helps.

 

Hope that does the trick. Let us know if you have further questions.

 

Have a nice day.

GuidoModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
3 people liked this

Re: Spotify Connect on Echo Dot stutters, choppy.

sboldt
Regular

Hello, I'm facing the same problem since a few weeks. I do own two Echo dots and on both I'm facing the described problem. This is really annoying, because I haven't had this error since I bought my first Echo dot in january 2017... 

2 people liked this

Re: Spotify Connect on Echo Dot stutters, choppy.

spotifymusic
Regular

I'm having the same issue with Spotify and Echo Dot (v2), the playback stutters and is choppy, and sometimes playback is temporarily in 'slow motion', crackly and garbled. The issue started over a month ago. It can happen at the start, middle or end of tracks. It's not possible to reproduce the stuttering by playing the same song again.

 

The Echo Dot is right next to my router and has full strength signal. I've tried it on 5Ghz and 2.4Ghz, rebooting in between network changes, and the issue always resurfaces. My router has QOS turned off. My connection speed is 200Mbps download / 32Mbps upload.

 

Echo Dot (v2) device firmware 618622620

 

On my router I monitored how Echo Dot downloads the song files, there's a short burst at the start of the song and it doesn't request more data before or after the stuttering playback. I can't find a pattern there.

 

It seems like Spotify/Echo Dot is having trouble processing the song and it is 'catching up'. I think there's something going wrong with Spotify and Echo Dot (v2) interacting together. Radio streams, and Amazon's streaming music service are fine on the Echo Dot (v2). It's only when playing Spotify with Echo Dot (v2) there's an issue.

 

Spotify playback on Echo Dot (V1) does not have this problem.

 

EDIT/UPDATE: 

The issue went away by following the exact instructions from the admin, read the instructions here:

https://community.spotify.com/t5/Other-Partners-Web-Player-etc/Spotify-Connect-on-Echo-Dot-stutters-...

 

Edit 2: Sadly, the studdering playback issue came back. Maybe the directions reset directions will work for some people so it might be worth trying it anyway.

Re: Spotify Connect on Echo Dot stutters, choppy.

Moderator
Moderator

Hey @SmileyKitKat@spotifymusic and @sboldt,

 

Thanks for getting back to us.

 

If you haven't yet, please factory reset your Amazon Dot and re-link it to your Spotify account via the Alexa App.

 

If your Amazon Dot is not yet close to your router, try to place it near the router to see if that makes any difference.

 

If it didn't help, let us know if the issue happens when streaming by asking Alexa to play the music, and if it happens when using Spotify Connect from the Spotify app, or perhaps both.

 

Looking forward to your reply. Have a nice day.

GuidoModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

Re: Spotify Connect on Echo Dot stutters, choppy.

gibbat
Casual Listener

Thanks so much , thought im the only one with that odd problem. Have echodot v2 still sitting on the same place since 2016 and this stuttering spotify playback started few months ago (august/september) not sure whats wrong. obviously when monitoring my prof wifi it seems that sometimes the echo retransmits few packets, the wifi is not overloaded. funny fact is that when having my notebook connected to the same accesspoint and not downloading just browsing internet the stuttering happens and has something in common when browsing the internet like the wifi devices battling download speed - but i cant believe at all.  from my understanding as previous posting describe the echo-dot for sure caching the spotify track instead of live streaming- i would expect this from the echo to cache minimum 1-2 mb of the track itself so a peek speed download (fireTV netflix , iPhone/tablets whatever) shouldnt cause problems. i crosschecked by downloading a contant big file with my notebook by fetching the full 100mbit internet speed and the issue does not getting more worse. therefore with/without having some download active the issue is happening during playback , i think theres some bug in the current echodot firmware on v2 since the last months which causes this. lets see how it works when echo v3 is delivered next week if its the same issue. 

on other room with echo speaker v2 (not dot) that issue with spotify doesnt happen.

as said by previous people the stuttering is only on spotify/connect and not on webradio played by echodot.

 

my notebook btw has bluetooth enabled for my mouse but that shouldnt cause any connectivity to the echodot - sometimes i think that when moving my bluetooth mouse the stuttering happens, will crosscheck this again but todays morning only bluetooth was enabled without that mouse active . anyone else using bluetooth during this strange issue?

 

thanks for sharing and discussing about this **bleep** problem

2 people liked this

Re: Spotify Connect on Echo Dot stutters, choppy.

spotifymusic
Regular

I tried what the admin suggested and my Echo Dot (v2) hasn't had any issues since I followed their instructions.

 

 1) Unlink your Spotify account via the Alexa App. 

In Amazon Alexa App, tap "Settings" > "Music" > "Spotify" > "Unlink Account from Alexa". 

 

2) Factory reset your Echo Dot (V2)

"To reset your Echo device, press and hold the "Microphone Off" and "Volume Down" buttons at the same time. Wait until the light ring turns orange (about 20 seconds)."

 

3) Link your Spotify account via the Alexa App. 

In Amazon Alexa App, tap "Settings" > "Music" > "Spotify" > etc...

 

Hope this works for you!

 

Side note, I just received the Echo Dot (V3) and it doesn't have any issues out of the box. Honestly, Echo Dot (v3) has better sound quality connected to a stereo than Echo Dot (V2) but that's another matter entirely.

 

 

Re: Spotify Connect on Echo Dot stutters, choppy.

sboldt
Regular

Although I'm pretty sure I've done a factory reset a frew month ago, I've again did one. I will report if it did help.

 

Re: Spotify Connect on Echo Dot stutters, choppy.

sboldt
Regular

After two days of testing after the factory reset I have to say that it didn't solve the problem. It only ocurred once or twice during the last two days - but it did. I did start the music by voice commands, but the problems occurred several minutes after starting the music, not shortly afterwards.  This is a REALLY annoying issue :-(

 

Re: Spotify Connect on Echo Dot stutters, choppy.

sboldt
Regular

Just checked if it works flawless whern I start music using the Spotify app. But it doesn't - same problems occurred first time after about 30 minutes of playback. :-(

SUGGESTED POSTS